Closed Bug 1202248 Opened 5 years ago Closed 5 years ago

Implement navigator.mozApps.mgmt for Desktop Apps (available in b2g)

Categories

(Core Graveyard :: DOM: Apps, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: anaran, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150905030205

Steps to reproduce:

I visited install.html hosted by
python -m SimpleHTTPServer
locally.



Actual results:

It can determine the app in question is installed, but when I press button
[Uninstall App]
I get this error.



Expected results:

I would expect it to work, according to
https://developer.mozilla.org/en-US/Apps/Build/JavaScript_API#Old_API_and_the_new_API
Attached file install.html
Attached file install.js
OS: Unspecified → Windows XP
Hardware: Unspecified → x86
Attachment #8657586 - Attachment mime type: application/x-javascript → text/plain
Component: Untriaged → DOM: Apps
Product: Firefox → Core
This, like so many of Component DOM: Apps, is still unconfirmed and unassigned.

This there a place to track progress in this area?
OS: Windows XP → All
Hardware: x86 → All
Version: 43 Branch → unspecified
Summary: TypeError: navigator.mozApps.mgmt is undefined → Implement navigator.mozApps.mgmt for Desktop Apps (available in b2g)
Apparently the mgmt property is currently only available for certified Firefox OS apps.

I can already install a Firefox OS app as desktop app.

Updating it does not work because
navigator.mozApps.mgmt.applyDownload(app)
is not available.
See http://mxr.mozilla.org/mozilla-central/source/dom/apps/Webapps.js#247

Could this property be exposed for platforms other than Firefox OS, where certified apps are not relevant?
Adrian: In the best of times, this would be a difficult bug to fix, but we haven't been investing in the runtime, and I don't see a prospect of that happening, so I've proposed that we disable it, which would mean that we won't fix this bug.  See the proposal for the details:

https://groups.google.com/forum/#!topic/firefox-dev/WV2XkVN3sWQ

(If you have thoughts about the proposal, I encourage you to join the discussion in the firefox-dev forum, as that's where it's taking place.  Discussion in this bug will be disconnected from it.)
Per bug 1238576, we're going to stop exposing navigator.mozApps on desktop/Android (except where MOZ_B2G is set, such as B2G Desktop), so we won't fix this bug.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.