onaudioProcess is not triggered

RESOLVED DUPLICATE of bug 934512

Status

()

Core
Web Audio
RESOLVED DUPLICATE of bug 934512
3 years ago
3 years ago

People

(Reporter: shyam.mohan1992, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

Tried to use WEB Audio API to record voice.


Actual results:

onaudioProcess did not get fired for the first time. 


Expected results:

onAudioprocess must have triggered as soon as the node is created.

PS:-it is working fine in chrome.

Updated

3 years ago
Component: Untriaged → Web Audio
Product: Firefox → Core
We would need more information to act on this because onaudioprocess is being triggered in some situations.
Is getUserMedia involved?  If so, this may be bug 934512.
If not, can you attach a testcase, please?
(Reporter)

Comment 2

3 years ago
Yes it involves getUserMedia. Thanks for directing
Changes in bug 916387 should mean that audioprocess is dispatched, but due to bug 934512, the input will be silent if a reference is not held to the stream from getUserMedia().
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Depends on: 916387
Resolution: --- → DUPLICATE
Duplicate of bug: 934512
You need to log in before you can comment on or make changes to this bug.