Closed Bug 1202990 Opened 4 years ago Closed 4 years ago

Add-on Manager needs special add-on to show add-on-versions

Categories

(SeaMonkey :: Themes, defect, minor)

SeaMonkey 2.38 Branch
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: haertetest_extrem, Unassigned)

Details

(Keywords: modern)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0 SeaMonkey/2.38
Build ID: 20150904215228

Steps to reproduce:

after update to SM 2.38 B1 the Addon-Manager shows queezed names of the installed add-ons.


Actual results:

just update to SM 2.38 Beta 1


Expected results:

Should show the normal size
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Attached image Add-On Manager 2.35.jpg
these two attachments show the 2.35 and the 2.38 beta 1 Addon-Manager window
With the Classic theme, things are probably OK. There were definitely changes in the add-on manager recently, and the Modern theme probably was not updated for those yet.
Workaround? This is what I get with the "Slim Add-ons Manager" and "Add-ons Manager - Version Number" extensions in place (plus a number of others, not AOM-related)

I'm on Linux64 trunk, maximized on a 1024x768 screen:
UA "Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40a1" ID:20150905054837 c-c:929b56b8c1ad97e816bd15e058bb068607648773 m-c:e816a7a854a333bda1447ab6c5b633233f322669
P.S. Oh, and I'm using the "EarlyBlue" theme plus a lightweight theme.
Component: General → Themes
Keywords: modern
Yes, the version of my EarlyBlue theme that I have in my repositories has already been adapted to the add-on manager changes, Modern still needs to be updated.
Also see <http://techdows.com/2015/08/firefox-40-make-add-ons-manager-to-display-version-number-for-extensions-and-plugins.html>

@reporter:
In  Add-On Manager 2.38 b1.jpg I see no add-on-version at all, not version number in inappropriate size.
Flags: needinfo?(haertetest_extrem)
(In reply to Rainer Bielefeld from comment #8)

> @reporter:
> In  Add-On Manager 2.38 b1.jpg I see no add-on-version at all, not version
> number in inappropriate size.

well that's the point!! Seamonkey 2.35 already shows the whole name and number of the Addon, but Seamonkey 2.38 Beta 1 only shows the squeezed Name of the Addon. Both screenshots from the small (normal) window size!!
Flags: needinfo?(haertetest_extrem)
(In reply to Mario from comment #9)
Technically the version number is not part of the add-on-name.

Current behavior is not a SeaMonkey bug, but intended for Firefox, and there will be no special arrangement for SeaMonkey.

The solution ("fix", if you want) for all (like me) who prefer to see the add-on-version directly in the list the add-on "Add-ons Manager - Version Number" <https://addons.mozilla.org/de/seamonkey/addon/amversionnumber/> is the solution.
Severity: normal → minor
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
OS: Windows 10 → All
Hardware: x86_64 → All
Resolution: --- → WONTFIX
Summary: Addon Manager shows squeezed Names → Add-on Manager needs special add-on to show add-on-versions
really funny that I should use an add-on that might use again RAM :-(
You need to log in before you can comment on or make changes to this bug.