Closed Bug 1203096 Opened 6 years ago Closed 6 years ago

Remove workaround from bug 1188045 when possible

Categories

(Firefox Build System :: General, defect)

41 Branch
defect
Not set
normal

Tracking

(firefox47 fixed)

RESOLVED DUPLICATE of bug 1188045
mozilla47
Tracking Status
firefox47 --- fixed

People

(Reporter: away, Assigned: ehsan.akhgari)

References

Details

Blocks: winclang
This no longer seems to be an issue.  In fact the original patch now causes a crash in e10s child process startup on debug builds because of this assertion <https://dxr.mozilla.org/mozilla-central/source/toolkit/xre/WindowsCrtPatch.h#126> triggering as a result of these DLLs not being delay loaded.

I'm going to back out the workaround.
Assignee: nobody → ehsan
https://hg.mozilla.org/mozilla-central/rev/a34e325a1746
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Hmm, so it turns out that this error only occurs when building with --enable-dmd.  I haven't investigated why yet, but we should revert this patch in the mean time.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I reduced this bug and posted the updated test case on the LLVM bug: https://llvm.org/bugs/show_bug.cgi?id=24291#c8
I will fix this in bug 1188045.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1188045
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.