Closed Bug 1203219 Opened 4 years ago Closed 4 years ago

[Safe Mode]Smartphone gets a bad state when user launches "Safe Mode" in a landscape mode

Categories

(Firefox OS Graveyard :: General, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, firefox44 fixed, b2g-master verified)

VERIFIED FIXED
FxOS-S8 (02Oct)
blocking-b2g 2.5+
Tracking Status
firefox44 --- fixed
b2g-master --- verified

People

(Reporter: MaxIvanov, Assigned: fabrice)

References

()

Details

(Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(3 files)

Attached file logs.txt
Description:
If a user launches "Safe mode" in a landscape mode they will get a broken menu. In a portrait mode everything work fine. 

Repro Steps:
1) Update a Aries to 20150908152248
2) Turn your phone off
3) Hold you phone in a landscape mode
4) Start you phone
5) While a phone is booting press and hold "Power" button

Actual:
"Safe mode" menu is broken.

Expected:
User should get a "Safe Mode" menu without any graphical issues 

Environmental Variables:
Device: Aries 2.5
Build ID: 20150908152248
Gaia: b81185d30e548f782770b852473ffb53c641a490
Gecko: b23b2fa33a9dcda59dbbca1d157eca3c32c5b862
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: (5/5)
See attached: (video clip, logs)
https://youtu.be/1Gcb0bg9hfY
This issue is reproducible on Aires 2.5 since thit option was implemented only for a foxfood builds.
Result: If a user launches "Safe mode" in a landscape mode they will get a broken menu.

Device: Aries 2.5
Build ID: 20150908152248
Gaia: b81185d30e548f782770b852473ffb53c641a490
Gecko: b23b2fa33a9dcda59dbbca1d157eca3c32c5b862
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]:
Safe mode opens in a terrible state when in landscape.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Very bad user experience. Blocks 2.5 with P1 priority
blocking-b2g: 2.5? → 2.5+
Priority: -- → P1
Since we only designed the gaia side to display nicely in portrait mode, this patch locks the screen to portrait during the initial safe mode startup.
Assignee: nobody → fabrice
Attachment #8664316 - Flags: review?(ferjmoreno)
Attachment #8664316 - Flags: review?(ferjmoreno) → review+
test case is created in Moztrap: https://moztrap.mozilla.org/manage/case/16730
Flags: in-moztrap+
https://hg.mozilla.org/mozilla-central/rev/e60e1de96fb3
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S8 (02Oct)
This bug has been verified as pass on latest build of Aries KK v2.5 and Flame KK v2.5 by the STR in comment 0.

Actual results: While a phone is booting, press and hold the "Power" button in landscape mode, user gets a "Safe Mode" menu without any graphical issues.

See attachment: Verified_Aries_v2.5.3gp
Reproduce rate: 0/10


Device: Aries KK 2.5(Pass)
Build ID               20150925003138
Gaia Revision          4bb17b24620818cbda0ba0c0d69e0ce3f914e1b7
Gaia Date              2015-09-23 16:06:39
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/eee4266046984718e4daa99d94ce820f3fd86d32
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150925.001452
Firmware Date          Fri Sep 25 00:15:01 UTC 2015
Bootloader             s1

Device: Flame KK 2.5(Pass)
Build ID               20150924150202
Gaia Revision          4bb17b24620818cbda0ba0c0d69e0ce3f914e1b7
Gaia Date              2015-09-23 16:06:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/001942e4617b2324bfa6cdfb1155581cbc3f0cc4
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150924.183612
Firmware Date          Thu Sep 24 18:36:29 EDT 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [MGSEI-Triage+]
Attached video Verified_Aries_v2.5.3gp
You need to log in before you can comment on or make changes to this bug.