Closed Bug 1203397 Opened 7 years ago Closed 7 years ago

Display TaskCluster Linux64 Static Analysis opt builds as "S", not "B"

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla44

People

(Reporter: ehsan.akhgari, Assigned: ehsan.akhgari)

References

Details

Attachments

(1 file)

Currently we display them as "tc(B)" which seems sub-optimal.  Please see <https://treeherder.mozilla.org/#/jobs?repo=try&revision=8efb63ce0fa3> for an example.
For job data submitted to Treeherder via its API (which is the case for everything apart from buildbot), the submitter gets to choose the job name and symbol (ie: we don't have the awful regexes and mapping).

As such this needs to be fixed in the taskcluster configs:
Component: Treeherder → Integration
Product: Tree Management → Taskcluster
Version: --- → unspecified
Summary: Display TaskCluster Linux64 opt builds as "S" → Display TaskCluster Linux64 Static Analysis opt builds as "S", not "B"
Hmm, modifying the TaskCluster config seems to cause the build to not show up at all on TreeHerder: <https://treeherder.mozilla.org/#/jobs?repo=try&revision=df59b6733814>  I tried setting groupSymbol and groupName to either the empty string or null and neither worked.  Dustin, do you have any idea why?
Flags: needinfo?(dustin)
Hm, I don't know what to suggest to *not* have a group symbol.  https://queue.taskcluster.net/v1/task/abSKU3CvR6aADDGoyibtyw shows `null` there, and nothing showed up.
Flags: needinfo?(dustin)
Hmm, I'm only guessing what a group symbol means, but I expect that they're used for grouping different jobs together in the TreeHerder UI.  If that is correct, then what I'm trying to do here is to add a standalone job that is not grouped together with any other jobs.  What's the right way to do that?
ok so I'm looking at the changes here: https://hg.mozilla.org/try/rev/1106fbef34e1

Some suggestions that might help out:

* groupSymbol could be '?'
* for group name we've used something like ""groupName": "Submitted by taskcluster"," before but I'm not sure if it's entirely necessary
Attachment #8660042 - Flags: review?(dustin) → review+
https://hg.mozilla.org/mozilla-central/rev/0cf091991709
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Assignee: nobody → ehsan
Component: Integration → Task Configuration
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.