Turn off signing requirements in Firefox 41 and 42

VERIFIED FIXED

Status

()

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mossop, Assigned: mossop)

Tracking

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox41+ verified, firefox42+ verified, firefox43 unaffected)

Details

Attachments

(1 attachment)

We've decided to push turning the pref for signing requirements on out to 43 so need to turn it off in aurora/beta. Forcing the pref on will be pushed out to 44.
Posted patch patchSplinter Review
As a simple pref change I'm going to assert that we don't need a review here, we also don't want to take this change on nightly so this just needs to land straight to aurora/beta
Attachment #8659315 - Flags: approval-mozilla-beta?
Attachment #8659315 - Flags: approval-mozilla-aurora?
Comment on attachment 8659315 [details] [diff] [review]
patch

Requiring add-ons to be signed by default is turned off for 41 and 42. Let's uplift to Beta41 and Aurora42.
Attachment #8659315 - Flags: approval-mozilla-beta?
Attachment #8659315 - Flags: approval-mozilla-beta+
Attachment #8659315 - Flags: approval-mozilla-aurora?
Attachment #8659315 - Flags: approval-mozilla-aurora+
Assigning to Vasilica for a quick check that this properly disabled.
Flags: qe-verify+
QA Contact: vasilica.mihasca
I can confirm that xpinstall.signatures.required pref is set to false by default in Firefox 42.0a2 (2015-09-11) and Firefox 41 Beta 9 (20150910171927) under Windows 7 64-bit, Ubuntu 14.04 32-bit and Mac OS X 10.10.5.

Also performed a brief check to ensure that no new issue were caused by this changing.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1191007
Although this was a "simple pref change", any problems between old addons and the v41 codebase are only just now coming to light, as we build the release candidate (see bug 1204324). I'm worried there may be more issues that we haven't discovered yet. It would have been nice to have longer bake time on this.
Blocks: 1135781
You need to log in before you can comment on or make changes to this bug.