HTMLMediaElement playing through Web Audio API glitches

RESOLVED DUPLICATE of bug 1203836

Status

()

Core
Web Audio
P1
normal
RESOLVED DUPLICATE of bug 1203836
2 years ago
2 years ago

People

(Reporter: ntim, Unassigned)

Tracking

({regression})

unspecified
regression
Points:
---

Firefox Tracking Flags

(firefox42 unaffected, firefox43+ fixed, firefox44 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
(Big) Testcase: http://nt1m.github.io/silhouette-audio-player/
(Reporter)

Updated

2 years ago
status-firefox42: --- → unaffected
status-firefox43: --- → affected
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 1

2 years ago
Created attachment 8659447 [details]
testcase.html

reduced testcase. I haven't tried to remove the file input, but this is already a reduced testcase.
(Reporter)

Updated

2 years ago
Summary: Audio playback is glitchy → HTMLMediaElement playing through Web Audio API glitches
(Reporter)

Updated

2 years ago
tracking-firefox43: --- → ?
Priority: -- → P1
See Also: → bug 1203836

Comment 2

2 years ago
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4f33bf3be1d07b080197cd8231c6365673c25fd7&tochange=0021aceac846

Regressed by: Bug 901633
Blocks: 901633
Keywords: regressionwindow-wanted

Comment 3

2 years ago
Via local build,
Last Good: 5b18471f2ff7
First Bad: f13da3f6b494
Recent regression in 43, tracking. 
Paul is this something you might take a look at?
tracking-firefox43: ? → +
Flags: needinfo?(padenot)
I'm landing the patch today, it's in bug 1203836.
Flags: needinfo?(padenot)
status-firefox44: --- → fixed
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1203836
The patch in bug 1203836 was uplifted to aurora 43, so I'm marking this fixed as well.
status-firefox43: affected → fixed
You need to log in before you can comment on or make changes to this bug.