Closed Bug 1203723 Opened 4 years ago Closed 4 years ago

[Settings] Long pressing a Settings option opens up a window menu.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED WORKSFORME
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: jthomas, Assigned: boris)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(1 file)

Description:
If the user long presses any of the categories within settings (except toggle options) a menu prompt will appear with the following options: "Copy Link, Open in new window, Open in new private window, Add link to home screen, Save linked file and Share link." 

Note: This bug may be related to Bug 1198522 since the user is able to open up menu options in other areas on the device as well.

Repro Steps:
1) Update a Aries to 20150908144744
2) Select Settings
3) Long press a Settings category that does NOT contain a Toggle Switch.

Actual:
A menu appears. Some options have functionality such as Share Link. Open Link has no functionality.

Expected:
It is expected that no menu will appear and that the settings category will be highlighted.

Environmental Variables:
Device: Aries 2.5 Kk Fullflash
Build ID: 20150909215207
Gaia: 47459eead04385e22f967012b824f5abdddcfb7c
Gecko: dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 4/4
See attached: Logcat & Video
This issue DOES occur on Flame 2.5.
Result: Menu appears after long pressing a Settings option.

Environmental Variables:
Device: Flame 2.5 Kk Fullflash (319mb)
Build ID: 20150909163019
Gaia: 47459eead04385e22f967012b824f5abdddcfb7c
Gecko: dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

------------------------------
This issue does NOT occur on Flame 2.2
Result: No menu appears after long pressing Settings options.

Environmental Variables:
Device: Flame 2.2 Kk Fullflash (319mb)
Build ID: 20150909183023
Gaia: 7a427e0f8aa6c185a9e22358006b97c19435ca4a
Gecko: 0d9c46d01861
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Systemsfe][Spark]
Please see bug 1198522 and check the regression window to see if it is the same.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
Re: comment 2: The windows don't match. This issue appeared much later than when bug 1198522 started to occur.
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20150901182223
Gaia: b75979ec8862bd5799a7c42e938d3f67be38d6ae
Gecko: fb720c90eb49590ba55bf52a8a4826ffff9f528b
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken
Device: Flame
BuildID: 20150901190524
Gaia: b75979ec8862bd5799a7c42e938d3f67be38d6ae
Gecko: 84e10095363e39a609813dfe638e5e3b44f5cc5f
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=fb720c90eb49590ba55bf52a8a4826ffff9f528b&tochange=84e10095363e39a609813dfe638e5e3b44f5cc5f

Caused by changes made in Bug 1121463.
Blocks: 1121463
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Boris this issues seems to have been caused by the changes for bug 1121463.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(boris.chiou)
(In reply to Jayme Mercado [:JMercado] from comment #5)
> Boris this issues seems to have been caused by the changes for bug 1121463. 
> Can you please take a look?

Sure!
Flags: needinfo?(boris.chiou)
Assignee: nobody → boris.chiou
See Also: → 1198522
Depends on: 1198522
See Also: 1198522
I think Bug 1198522 can also fix this bug.
Blocks 2.5 with a P2 priority.
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
Status: NEW → ASSIGNED
Whiteboard: [2.5-Daily-Testing][Systemsfe][Spark] → [2.5-Daily-Testing][Spark]
Keywords: qawanted
Add qawanted because Bug 1198522 should fix this problem as well.
Verified that this issue is no longer occurring on latest Flame 2.5 and Aries. Long pressing on a Settings category option does not make any kind of menu appear.

Device: Flame 2.5 (319MB memory)
BuildID: 20151006030203
Gaia: 60cdaa3d3424db3432dc903e7f9c6c8fa099c06d
Gecko: 3edc8d4a1e198314f5d7ebd2967b85842beef602
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Aries 2.5
BuildID: 20151008110640
Gaia: 4973f57cd8f9a62a95f783a24eac32da2bde99fc
Gecko: a955ea9382afedd66ea0da21fcd2932465168d84
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
Closing this as WFM.  Please reopen if it occurs again.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.