[Cost Control] Browser usage will be higher than total usage if data is reset while watching a youtube video

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: AdamA, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(2 attachments)

Created attachment 8659562 [details]
logcat_20150910_1412.txt

Description:
If the user is watching a youtube video and goes to the cost control app and resets the usage total it will show that the browser has used more mobile data than the total amount.

Prerequisite:
Usage/cost control has been set up.

Repro Steps:
1) Update a Aries to 20150909215207
2) Open Browser and begin playing a youtube video using mobile data
3) Press the home button and open usage app
4) Reset the data usage
5) Return to youtube video and watch it for a moment
6) return to usage app
7) Pbserve used mobile data

Actual:
the used browser mobile data is higher than total mobile data

Expected:
It is expected the theusage for any single app is less than the total

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150909215207
Gaia: 47459eead04385e22f967012b824f5abdddcfb7c
Gecko: dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 10/10
See attached: screenshot, logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20150910030223
Gaia: 47459eead04385e22f967012b824f5abdddcfb7c
Gecko: dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Result:
The Browser usage is higher than the total mobile usage.
----------------------------------
This issue DOES NOT repro in Flame 2.2.

Environmental Variables:
Device: Flame 2.2 [Full Flash]
BuildID: 20150909183023
Gaia: 7a427e0f8aa6c185a9e22358006b97c19435ca4a
Gecko: 0d9c46d01861
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
the browser data is less than the total
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.5-Daily-Testing][Spark]
(Reporter)

Comment 2

3 years ago
Created attachment 8659587 [details]
data discrepency
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
Keywords: regression
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: jthomas
CentralRegression Window 

Last Working
Environmental Variables:
Flame 2.5
BuildID: 20150508103602
Gaia: 3692ad2cf3a047cc66f58f655a56b6ec559ef253
Gecko: cef2b76b082d
Version: 40.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken
Environmental Variables:
Device: Flame 2.5
Build ID: 20150509033302
Gaia: 3692ad2cf3a047cc66f58f655a56b6ec559ef253
Gecko: 9c0bb1e02555
Version: 40.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Last Working gaia / First Broken gecko - This issue DOES occur.
Gaia: 3692ad2cf3a047cc66f58f655a56b6ec559ef253
Gecko: 9c0bb1e02555

Last Working gecko / First Broken gaia - This issue does NOT occur.
Gecko: cef2b76b082d
Gaia: 3692ad2cf3a047cc66f58f655a56b6ec559ef253

Central Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cef2b76b082d&tochange=9c0bb1e02555

This issue occurs most likely due to Bug 1162283
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Jared can you please take a look at this?  The changes for bug 1162283 seem to have caused this issue.
Blocks: 1162283
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(jaws)
I don't understand how something within desktop Firefox could cause an issue with a Firefox OS app. Vivien, have you looked in to this?
Flags: needinfo?(jaws) → needinfo?(21)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][Low_QA]
Closing as wontfix due to Firefox OS work being stopped.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(21)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.