If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

element cannot be dragged unless event.dataTransfer.setData() is called.

RESOLVED DUPLICATE of bug 725156

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 725156
2 years ago
2 years ago

People

(Reporter: Yay295, Unassigned)

Tracking

40 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
What did you do (part 1)?
I set an element to `draggable="true"` and set `ondragstart="myGlovalVar=this"`. I did not call `event.dataTransfer.setData()`.

What happened (part 1)?
The element could not be dragged.

What should have happened (part 1)?
I should have been able to drag the element.
Note that implicitly draggable elements (links, images, etc.) on my page could be dragged just fine.


What did you do (part 2)?
I set an element to `draggable="true"` and set `ondragstart="myGlovalVar=this"`. I did call `event.dataTransfer.setData()` (though I did not use it).

What happened (part 2)?
The element could be dragged.


Other than the implicitly draggable elements mentioned, the element tag does not seem to affect this.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 725156
You need to log in before you can comment on or make changes to this bug.