Don't allow trailing comma in destructuring array

RESOLVED DUPLICATE of bug 1041341

Status

()

defect
RESOLVED DUPLICATE of bug 1041341
4 years ago
4 years ago

People

(Reporter: anba, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(Reporter)

Description

4 years ago
Tests cases:
---
var [...a, ] = [];
[...a, ] = [];
---

Expected: Throws SyntaxError
Actual: No SyntaxError

ES2015, 13.3.3 Destructuring Binding Patterns, 12.14.5 Destructuring Assignment
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041341
You need to log in before you can comment on or make changes to this bug.