Scrollbar grippers are barely visible since switch to GTK3

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: pwd.mozilla, Unassigned)

Tracking

43 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(4 attachments)

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150817085917
Reporter

Updated

4 years ago
Blocks: 1186748
Reporter

Updated

4 years ago
Blocks: gtk3, ship-gtk3
How do these compare with grippers in other GTK+ 3 apps or in the dialog from
File -> Open File?
As noted by Karl, can we potentially get some screenshots to compare how they appear in other gtk3 apps as a control?
Flags: needinfo?(pwd.mozilla)
Whiteboard: [gfx-noted]
Reporter

Comment 3

4 years ago
Flags: needinfo?(pwd.mozilla)
Reporter

Comment 4

4 years ago
Reporter

Comment 5

4 years ago
The contrast in the open dialog seems better. With Gimp, the grippers have markings on them for the main window, however if you look to the top right, the contrast seems as bad as what we have.
Is there actually a difference in the scrollbars of the open dialog and the bugzilla page or just in the background of the page?

GIMP uses an older version of the GIMP Toolkit (GTK) and so looks different.
I don't see a difference between the Open File dialog scrollbar and the scroll bar on bugzilla page at those pictures. 

But scrollbar look depends on actual theme - for instance Fedora/Gtk gtk3-3.16 uses overlay scrollbars which are activated on mouse over and are transparent (reproducible in the Open File dialog for instance). So we definitely miss some pieces of scrolbar themes.
I just tested the Ambiance theme (which is default in Ubuntu) and the scroll bars looks exactly the same as in other Gtk3 apps there. The thumb should be more visible but IMHO that's a bug in the theme, not in Firefox.
Closing as a theme "bug"- Ambiance's scrollbar style changed in GTK3.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
Reporter

Comment 10

4 years ago
Have you filed a bug against Ambiance then? Scrollbars are a huge part of our user experience, if we're certain the issue is with the theme and we're not going to try and compensate for the shortfalls on our end, then we need to at least try and champion an improvement upstream.
This sounds like a personal preference issue.  I don't think the thumb needs to be grabbed right on the gripper, so there's no need to have a gripper.

Gecko's solution is a respect the user's chosen theme.

Feel free to file a bug with the distro if you don't like the default theme chosen.
Reporter

Comment 12

4 years ago
Accessibility is a personal preference really?
(In reply to Paul [pwd] from comment #12)
> Accessibility is a personal preference really?

Please file a bug where it's broken - which is Ambiance theme at Ubuntu. They should fix that for all applications, not just for Firefox.
Reporter

Comment 14

4 years ago
This experience is frustrating and unbecoming of Mozilla.
(In reply to Paul [pwd] from comment #10)
> Have you filed a bug against Ambiance then? Scrollbars are a huge part of
> our user experience, if we're certain the issue is with the theme and we're
> not going to try and compensate for the shortfalls on our end, then we need
> to at least try and champion an improvement upstream.

Looks like this is a known bug with ubuntu-themes- there are some styling changes that you may find useful in the bug:

https://bugs.launchpad.net/ubuntu/+source/ubuntu-themes/+bug/721786

Sorry, but we really can't reasonably work around this in Firefox without negatively affecting system styling (we really want to be consistent with the way GTK draws due to the myriad of different themes and versions). I believe there are plans to switch to using overlay scrollbars for GTK 3.16 as well.
You need to log in before you can comment on or make changes to this bug.