Closed Bug 1204513 Opened 6 years ago Closed 6 years ago

DOM Full Screen should be really full screen

Categories

(SeaMonkey :: UI Design, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.41

People

(Reporter: neil, Assigned: neil)

References

()

Details

User Story

DOM full screen test:
https://developer.mozilla.org/samples/domref/fullscreen.html

Attachments

(2 files)

Normal F11 full screen doesn't hide the navigation bar or tabbar by design. However DOM full screen should hide everything. We can detect DOM full screen by looking at the mozFullScreen property on the document.

Note that this bug is not about turning on DOM full screen by default, as there are various warnings and permissions that should be implemented first.
Attached patch Proposed patchSplinter Review
1. Hide the tab bar when DOM full screen is active
2. The navbar is not special when entering DOM full screen
3. Ensure the navbar is hidden when exiting full screen
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8660746 - Flags: review?(philip.chee)
Comment on attachment 8660746 [details] [diff] [review]
Proposed patch

In Normal mode:
> 1. Hide the tab bar when DOM full screen is active
Tab bar is hidden
> 2. The navbar is not special when entering DOM full screen
Nav bar is hidden
> 3. Ensure the navbar is visible when exiting full screen
Nav bar is visible when exiting DOM full screen

All chrome is hidden in DOM full screen mode. There is a thin strip of something across the top. It's not the full screen toggler since we don't have one.
Normal UI restored on exiting DOM full screen.

In F11 full screen mode:
> 1. Hide the tab bar when DOM full screen is active
> 2. The navbar is not special when entering DOM full screen
Tab bar and Nav bar remain visible on entering DOM full screen.
> 3. Ensure the navbar is visible when exiting DOM full screen
Nav bar is visible when exiting DOM full screen
Attachment #8660746 - Flags: review?(philip.chee) → review+
TODO? DOM full screen should:
1. hide findbar if open
2. hide notification box
3. hide sidebar
Attached patch Hide more stuffSplinter Review
Attachment #8662050 - Flags: review?
Comment on attachment 8662050 [details] [diff] [review]
Hide more stuff

Bah, Bugzilla ate my reviewer :-( [I blame the autocomplete.]
Attachment #8662050 - Flags: review? → review?(philip.chee)
Comment on attachment 8662050 [details] [diff] [review]
Hide more stuff

Sorry for the delay r+
Attachment #8662050 - Flags: review?(philip.chee) → review+
Pushed comm-central changeset 884d1267eff3.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.41
You need to log in before you can comment on or make changes to this bug.