Closed Bug 120453 Opened 23 years ago Closed 22 years ago

Opening a forwarded/attached mail message should be displayed in message window

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 143565

People

(Reporter: KaiE, Assigned: sspitzer)

References

Details

Make sure your mail settings are "forward as attachments".
Send yourself a very simple test message.
Fetch that message, forward it to yourself.
Fetch the forwarded message.
One attachment is shown in that message as expected.
Double click the attachment.

Actual behaviour: A new navigator window opens and the plaintext source of
attached/forwarded message is displayed.

Expected behaviour: The message should be shown in a mail message window
instead. The same window type you get, when you double click a message in a
folder listing.
Blocks: 115209
QA Contact: esther → trix
cc'ing Scott.

I digged around a little bit.
I think we either need to change the implementation of openAttachment to check
the mime type for message/rfc822, and open a message window instead of loading
into the docshell, or, we need to make the docshell aware of this mime type, and
change the docshell implementation to open a separate message window whenever
this mime type is seen.

Which of both do you prefer?

This is a dup of bug 143565 which contains more information...

*** This bug has been marked as a duplicate of 143565 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
verified dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.