Closed Bug 1204655 Opened 4 years ago Closed 4 years ago

Respond to a main launcher intent with category APP_BROWSER selector

Categories

(Firefox for Android :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 43
Tracking Status
firefox43 --- fixed

People

(Reporter: tynn, Assigned: tynn)

References

Details

Attachments

(1 file)

Launching an intent created with Intent.makeMainSelectorActivity(Intent.ACTION_MAIN, Intent.CATEGORY_APP_BROWSER) starts any other browser but Firefox or none if Firefox is the only Browser installed.
Attached patch bug1204655.patchSplinter Review
Hallo Michael, I've just added the APP_BROWSER category to the only launcher intent available, which resolves the issue and shouldn't have any side effects.
Attachment #8660936 - Flags: review?(michael.l.comella)
Hey Christian, I'll get to this tomorrow.
Assignee: nobody → tynn.dev
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 8660936 [details] [diff] [review]
bug1204655.patch

Review of attachment 8660936 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, Christian! Thanks!

try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=e4df58168e7a

Out of curiosity, how did you find out about this bug? Are there many applications that create intents this way?
Attachment #8660936 - Flags: review?(michael.l.comella) → review+
Keywords: checkin-needed
I've used this intent once and my tests failed on one device running Firefox and no other browser. But I don't know of any other application using it.
https://hg.mozilla.org/mozilla-central/rev/90ad1f7de0b0
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Duplicate of this bug: 1162066
You need to log in before you can comment on or make changes to this bug.