React Source Map breakpoints jump to html files

RESOLVED DUPLICATE of bug 1400856

Status

()

Firefox
Developer Tools: Debugger
RESOLVED DUPLICATE of bug 1400856
2 years ago
2 months ago

People

(Reporter: jsantell, Unassigned)

Tracking

(Blocks: 1 bug)

43 Branch
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

Attachments

(3 attachments)

Created attachment 8661028 [details]
debugger.gif

View attachment.

When setting bp's in the jsx files, they appear on the index.html in the sources list, and when switching to the index.html, there as well. Removing doesn't seem possible, even after refresh.

This is on Nightly 9/9/2015, recreated in Aurora as well. Can be recreated via this[0] react demo

[0] https://github.com/osnr/dagre-react/blob/master/example/index.html
Actually probably not source mapped, as it's loaded in via script tag (which I'm guessing the react runtime injects the compiled JS) -- so if this isn't a source map issue, maybe we shouldn't make non-JS files look "debuggable"?
Whiteboard: [platform-rel-Facebook][platform-rel-ReactJS]
platform-rel: --- → ?
platform-rel: ? → ---
Whiteboard: [platform-rel-Facebook][platform-rel-ReactJS]

Updated

6 months ago
Blocks: 1339970
Created attachment 8869470 [details]
new debugger

I just got this example setup and I'm not seeing the jsx files at all in the new debugger.  The old debugger shows them but they are missing from the new one.  Lemme file that issue with the new debugger and then we can see if this problem still exists.
Created attachment 8869472 [details]
old debugger

Comment 4

2 months ago
This is a <script> with a sourceMappingURL but no sourceURL.
This problem is being handled in bug 1224078.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1224078

Comment 5

2 months ago
It's a dup but I used the wrong bug.
Duplicate of bug: 1400856
You need to log in before you can comment on or make changes to this bug.