Closed Bug 120505 Opened 20 years ago Closed 20 years ago

Unable to use Browser if Messenger has a dialog open

Categories

(SeaMonkey :: UI Design, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 65521

People

(Reporter: jg, Assigned: trudelle)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226
BuildID:    2001122617

When I leave a "File->Save as" open in Messenger I am no longer able to use the
mouse in Mozilla browser if I select that window.

This applys to all of the parts that make up Mozilla, even if there is a "unable
to find DNS of website" error that seems to grab all window input from the
mouse.  Page Up and page down do not work on the page either

It is possible to use TAB to move arround the page, if there are some links or
text boxes to tab through but this is not an ideal solution.  Sometimes popup
boxes appear from other websites I am viewing, but because I am currently in
another window I do not see the popup and can not input into ANY windows until i
find that popup and close it etc.

Reproducible: Always
Steps to Reproduce:
1.go to site in mozilla
2.do something else that makes a popup window, eg file save in another window,
or a dns error popup etc
3. see that your window you are browsing the site from 1. is now unable to do
anything, I expeeriecned this when inputing a bug report! haha

Actual Results:  No input to other windows, when popups are about, unless you
can hack your way about with TAB (no page up or down works)

Expected Results:  mouse input and keyboard input should be directed to the
window that is selected, not locked to a popup that I was unware had "popped up"
behind my other windows, as the popup is relevent to its particular window.

it would be better to only "lock" the input to that window, not the whole of
mozilla, IMO
This looks like bug 65521, with a dash of bug 99728

*** This bug has been marked as a duplicate of 65521 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.