[Gallery] When you play Video, it does not show time how long the video is.

VERIFIED FIXED in FxOS-S8 (02Oct)

Status

P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: vbelonenko, Assigned: aosmond)

Tracking

({regression})

unspecified
FxOS-S8 (02Oct)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8661502 [details]
logcat_20150915_1606.txt

Description:
User starts playing video inside the gallery app and it only shows time when it starts playing and does not shows how long the video is.

Repro Steps:
1) Update a Aries to the RC4 build.
2) Sideload the update zip to update to the dogfood test build 20150915152315
3) Open Camera app and Record a Video.
4) Open the "Gallery" app.
4) Tap on the "Video" icon and play the video. 
5) Observe that video scroll bar does not show time length on the right side.


Actual:
 Playing video inside the gallery app and it only shows time when it starts playing.

Expected:
Video supposed to show length of the clip time and start to stop time.

Environmental Variables:
Device: Aries 2.5
Build ID: 20150915152315
Gaia: d2e5c49440bf8410ae747b15c0dd11c54053ef3e
Gecko: 112ed0121136e9e642e34382256ec73d33bb1b86
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 5/5 100%
See attached: Logcat and video
(Reporter)

Comment 1

3 years ago
This issue does not occur on Flame 2.2
Result: When you play Video, it shows time bar how long the video is on Flame 2.2


Environmental Variables:
Device: Flame 2.2 Full FLash (319 mb)
Build ID: 20150914032507
Gaia: 7a427e0f8aa6c185a9e22358006b97c19435ca4a
Gecko: 0d9c46d01861
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


This issue does occur on Flame 2.5
Result: When you play Video, it does not show time bar how long the video is on Flame 2.5

Environmental Variables:
Device: Flame 2.5 kk Full Flash (319 mb)
Build ID: 20150915030230
Gaia: e6994410dcc88bfead0e44620a065220b7f12290
Gecko: c69e31de9aec2b9e8c0b3128ac6dc3897aa7381f
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage+]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression
This is a regression. Let's get a window here.
blocking-b2g: --- → 2.5?
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: jthomas
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
B2G Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20150730044442
Gaia: 5e31fb6f88cd8c42e53214183defa2ffd455ea00
Gecko: 3595d5849dfc
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Environmental Variables
Device: Flame 2.5
BuildID: 20150730051841
Gaia: d77579a3d6224ceefcdf26b7d2a9785a2de45c87
Gecko: 63c691cc05d8
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Last Working gaia / First Broken gecko - This issue does NOT occur with broken Gecko
Gaia: 5e31fb6f88cd8c42e53214183defa2ffd455ea00
Gecko: 63c691cc05d8

Last Working gecko / First Broken gaia - This issue DOES occur with broken Gaia
Gecko: 3595d5849dfc
Gaia: d77579a3d6224ceefcdf26b7d2a9785a2de45c87

B2G Inbound Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/5e31fb6f88cd8c42e53214183defa2ffd455ea00...d77579a3d6224ceefcdf26b7d2a9785a2de45c87

This issue is caused by Bug 1164200
Blocks: 1164200
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Andrew this issues seems to have been caused by the changes for bug 1164200.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(aosmond)
Created attachment 8665167 [details] [review]
[gaia] aosmond:bug1205096 > mozilla-b2g:master
(Assignee)

Comment 6

3 years ago
Comment on attachment 8665167 [details] [review]
[gaia] aosmond:bug1205096 > mozilla-b2g:master

This one is a little embarrassing. I should have seen the other onloadedmetadata handler and realized it was replacing it :|.
Flags: needinfo?(aosmond)
Attachment #8665167 - Flags: review?(dflanagan)
(Assignee)

Updated

3 years ago
Assignee: nobody → aosmond
Status: NEW → ASSIGNED
Comment on attachment 8665167 [details] [review]
[gaia] aosmond:bug1205096 > mozilla-b2g:master

Looks good to me.  This bug might be enough to get me to start using addEventListener() everywhere.  The only real advantage to the 'on' attribute is how easy it is to set them to null when done.

Thanks for fixing it.
Attachment #8665167 - Flags: review?(dflanagan) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/5d166bb68b7b99175d36001f19f7426a292db3e6
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S8 (02Oct)
Keywords: checkin-needed

Comment 9

3 years ago
This bug has been verified as "pass" on the latest eng/user build of Flame KK 2.5 and Aries KK 2.5 by the STR in comment 0.

Actual results: Video can show the total time at the right of the control bar.
See attachment: Verify_Flame_v2.5_eng.3gp
Reproduce rate: 0/10

Device: Flame KK 2.5 eng  (Pass)
Build ID               20150928150204
Gaia Revision          01ffe82cf088ca8fda9fe6783dc5cad2c3dde01c
Gaia Date              2015-09-28 08:49:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/031db40e2b558c7e4dd0b4c565db4a992c1627c8
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150928.182514
Firmware Date          Mon Sep 28 18:25:26 EDT 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 eng  (Pass)
Build ID               20150929001133
Gaia Revision          4c0a6d4e8501368db8e5d6029a41db985ef1252a
Gaia Date              2015-09-28 13:57:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/79a5b2968d01512470eb6c25d6638d8b9565575e
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150928.232925
Firmware Date          Mon Sep 28 23:29:34 UTC 2015
Bootloader             s1

Device: Flame KK v2.5 user  (Pass)
Build ID               20150928150204
Gaia Revision          01ffe82cf088ca8fda9fe6783dc5cad2c3dde01c
Gaia Date              2015-09-28 08:49:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/031db40e2b558c7e4dd0b4c565db4a992c1627c8
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150928.182509
Firmware Date          Mon Sep 28 18:25:21 EDT 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 user  (Pass)
Build ID               20150929000548
Gaia Revision          4c0a6d4e8501368db8e5d6029a41db985ef1252a
Gaia Date              2015-09-28 13:57:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/79a5b2968d01512470eb6c25d6638d8b9565575e
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150928.232620
Firmware Date          Mon Sep 28 23:26:28 UTC 2015
Bootloader             s1

Device: Aries KK v2.5 after OTA  (Pass)
Build ID               20150928133112
Gaia Revision          01ffe82cf088ca8fda9fe6783dc5cad2c3dde01c
Gaia Date              2015-09-28 08:49:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/031db40e2b558c7e4dd0b4c565db4a992c1627c8
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150917.224210
Firmware Date          Thu Sep 17 22:42:18 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [MGSEI-Triage+]
status-b2g-master: affected → verified

Comment 10

3 years ago
Created attachment 8667117 [details]
Verify_Flame_v2.5_eng.3gp
You need to log in before you can comment on or make changes to this bug.