'label' attribute of <option> elements is not interpreted

RESOLVED DUPLICATE of bug 40545

Status

()

defect
RESOLVED DUPLICATE of bug 40545
4 years ago
2 years ago

People

(Reporter: sebo, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

()

The HTML standard says that the 'label' attribute of an <option> tag contains a user-visible label.[1]

Chrome, Opera and IE display the label for the option, Firefox not.

Sebastian

[1] https://html.spec.whatwg.org/multipage/forms.html#the-option-element
Confirmed. Works correctly in both IE and Chrome but not in FF. You can test it here: http://www.w3schools.com/tags/tryit.asp?filename=tryhtml_option_label

Mozilla Dev Wiki lists it as supported since v1.0:
https://developer.mozilla.org/en-US/docs/Web/HTML/Element/option

I tried a few older builds, including ancient 4.0 and it just wouldn't work any version that i have tried.
(In reply to David H. from comment #1)
> Mozilla Dev Wiki lists it as supported since v1.0:
> https://developer.mozilla.org/en-US/docs/Web/HTML/Element/option

I've added a compatibility note to that page referring to this bug. The note that was previously there was actually related to https://developer.mozilla.org/en-US/docs/Web/API/HTMLOptionElement.

Furthermore I've updated the URL field with an improved test case.

Sebastian
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: option-label
You need to log in before you can comment on or make changes to this bug.