MSVC2015 internal error compiling js part

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
8 months ago

People

(Reporter: xidorn, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1

Firefox Tracking Flags

(firefox43 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8661700 [details]
build output

I frequently run into internal error when compiling js part of Firefox with MSVC2015.

The attachment shows an example of such internal error.

I meet this error almost every time when I update the local tree. Executing 'mach build' again would make it actually finish.

My .mozconfig for the attached log:

ac_add_options --enable-application=browser
ac_add_options --enable-accessibility
ac_add_options --enable-debug
ac_add_options --enable-warnings-as-errors

ac_add_options --disable-crashreporter
ac_add_options --disable-updater
ac_add_options --disable-installer
ac_add_options --disable-maintenance-service

mk_add_options AUTOCLOBBER=1
mk_add_options MOZ_PACKAGE_JSSHELL=1
mk_add_options MOZ_PSEUDO_DERECURSE=1
mk_add_options MOZ_MAKE_FLAGS=-j7

ac_add_options --target=x86_64-pc-mingw32
ac_add_options --host=x86_64-pc-mingw32
ac_add_options --disable-optimize
You should report this to Microsoft at https://connect.microsoft.com/. If you can reliably reproduce it you should provide STR. You may be able to use /LINKREPRO to generate a testcase for Microsoft, described here:
https://support.microsoft.com/en-us/kb/974229
(Reporter)

Comment 2

3 years ago
I believe I can reproduce this every time if I do clobber before build... I don't have a finer-grained STR, though.
(Reporter)

Comment 3

3 years ago
FWIW, it seems chromium meets this issue as well. See https://code.google.com/p/chromium/issues/detail?id=482671 and they've reached Microsoft for it.

Comment 4

3 years ago
(In reply to Xidorn Quan [:xidorn] (UTC+8) from comment #3)
> FWIW, it seems chromium meets this issue as well. See
> https://code.google.com/p/chromium/issues/detail?id=482671 and they've
> reached Microsoft for it.

May compiler ICE bugs may look similar, it'd still be really nice if you can report the bug you're seeing to Microsoft.  Let them figure out if that is the same issue as what Chromium has been seeing.

Look at it this way, if you don't report the bug, it may not get fixed.  :-)
(Reporter)

Comment 5

3 years ago
I believe I haven't seen this issue since I upgraded to VS2015 Update 1. So it seems this issue has been fixed by Microsoft.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.