Closed Bug 1205286 Opened 4 years ago Closed 4 years ago

About:home sync icon should link to about:preferences#sync

Categories

(Firefox :: Sync, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 44
Tracking Status
firefox44 --- verified

People

(Reporter: rfeeley, Assigned: zaach)

Details

Attachments

(1 file, 2 obsolete files)

About:home sync icon should open about:preferences#sync in a new tab but currently links to about:accounts?entrypoint=abouthome (not in a new tab)
It does link to the Sync pref pane in the logged in state, but links to about:accounts in the logged out state.
Flags: firefox-backlog+
Priority: -- → P1
It should link to about:preferences#sync in both cases. Zach please come to the rescue! This bug keeps showing up in user testing.
Flags: needinfo?(zack.carter)
Assignee: nobody → zack.carter
Flags: needinfo?(zack.carter)
Comment on attachment 8667067 [details] [diff] [review]
Make about:home Sync icon always link to about:preferences#sync

Review of attachment 8667067 [details] [diff] [review]:
-----------------------------------------------------------------

This looks great, although we do still need the entrypoint functionality (sorry - I probably mislead you about that) - see https://dxr.mozilla.org/mozilla-central/source/browser/base/content/browser-fxaccounts.js#473 for an example. If you add that tweak (including having the test check that) it will be golden!
Attachment #8667067 - Flags: review?(markh) → feedback+
Add the entrypoint.
Attachment #8667067 - Attachment is obsolete: true
Attachment #8667433 - Flags: review?(markh)
Attachment #8667433 - Attachment is obsolete: true
Attachment #8667433 - Flags: review?(markh)
Attachment #8667437 - Flags: review?(markh)
Comment on attachment 8667437 [details] [diff] [review]
Make about:home Sync icon always link to about:preferences#sync

Review of attachment 8667437 [details] [diff] [review]:
-----------------------------------------------------------------

awesome
Attachment #8667437 - Flags: review?(markh) → review+
https://hg.mozilla.org/mozilla-central/rev/5f2acd473d59
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 44
I have reproduced the bug in nightly 43.0a1 (2015-09-16)(Build ID:20150916030203) with the instruction from comment 0 and linux lite 32 bit

Bug is fixed now on latest nightly 44.0a1 (2015-10-14)(Build ID:20151014030223)
User Agent : Mozilla/5.0 (X11; Linux i686; rv:44.0) Gecko/20100101 Firefox/44.0

[bugday-20151014]
QA Whiteboard: [bugday-20151014]
I have reproduced the bug in Firefox 42.0; Build ID :20151029151421;  User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:42.0) Gecko/20100101 Firefox/42.0 .

The fix works for me in Firefox 44.0a2; Build ID: 20151103004217; User Agent : Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:44.0) Gecko/20100101 Firefox/44.0 .

From comment 10 , it seems that the fix is also verified in Linux i686. I am marking the bug as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.