controls do not lose :focus when the window does

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: ian, Assigned: saari)

Tracking

Trunk
mozilla1.1alpha
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
STEPS TO REPRODUCE
   1. Open a dialog, e.g. File | Page Setup
   2. Focus a control, e.g. the Orientation drop down or the Cancel button.
   3. Alt Tab to another window.

EXPECTED RESULTS
   The control focussed in step 2 should lose its :focus styles as soon as the
   window itself loses focus.

ACTUAL RESULTS
   The control does not lose its focus until you mouse over it (with it in the
   background, that is).

Maybe we are actually removing the focus internally but just not repainting?
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla1.1

Updated

17 years ago
QA Contact: madhur → rakeshmishra

Updated

17 years ago
Blocks: 140346

Comment 1

16 years ago
Created attachment 99094 [details]
A test case

Reproduction instructions:
   1. Set focus on some input control (border and background should change)
   2. Move focus to another tab: Click on existing tab, or open 
      a new tab (ctrl+T) or right click on a link and open it in new tab
   3. Switch back to a tab with this document (focus remains on 
      previously focused control)
   4. Set focus to another control - both controls appear to be 
      in focus, previous control does not lose focus
   5. Continue if you wish "focus" on more controls :)

I hope this will make solving this bug easier. 
TNX!
Stefan

Updated

16 years ago
QA Contact: rakeshmishra → trix

Comment 2

16 years ago
I tried the testcase (an excellent one, btw) in attachment 99094 [details] with build
2003020708 under XP Pro SP1 and noticed the focus bug on the input element
(focus remains on previously focused control).

Comment 3

15 years ago
.
Assignee: joki → saari
QA Contact: trix → ian

Comment 4

15 years ago
I tried the testcase with Mozilla 1.7b build 2004031309)under XP Pro SP1 and I
got the expected results (step 4): the previous control lose focus and the other
(next) control got focus.

WORKSFORME

Comment 5

14 years ago
The test case works for me, but the case in Comment #0 behaves exactly as described.

{ WinXP SP2, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3)
Gecko/20040831 }

Comment 6

14 years ago
I've exercised the steps given in the test case, and the described behaviour
cannot be reproduced.  This problem may have been fixed recently.

Using Mozilla 1.8a4 build 2004092705
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a4) Gecko/20040927

Closing this bug, since the issue described above can no longer be reproduced. 
Ian, feel free to reopen this bug if you see this again in future builds.  Thanks!
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.