Closed Bug 1205619 Opened 5 years ago Closed 4 years ago

Mousedown event doesn't fire the first time after context menu was opened on chrome textfield / <tree>s (or menupopup from <menulist> was opened)

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

43 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 358864

People

(Reporter: lagu, Unassigned)

References

()

Details

User Story

STR:   (Win7_64, Nightly 44, 32bit, ID 20150930030231, new profile, safe mode)
1. Open the following "data:" url or click URL in the form above
>   data:text/html,<html onclick="alert('clicked')" oncontextmenu="alert('contextmenu')">

2. Right-click text in urlbar
3. Click page content
4. Right-click text in urlbar
5. Right-click page content

Result:    There's no alert in Step 3 - 'click' event doesn't fire (also tested with toolbar buttons)
           There IS alert in Step 5 - 'contextmenu' event fires.   [OK]
Expectations: Click event should fire in Step 3.
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.85 Safari/537.36

Steps to reproduce:

Open a webpage like google.com
make a right click in the address bar, and select nothing in the context menu
Click on any link in the webpage


Actual results:

the context menu is closed


Expected results:

the webpage should open, as expected and the context menu is closed.
Component: Untriaged → Event Handling
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Summary: After right click in url bar without selection anything, no klick on webpage is triggererd → After right click in url bar without selection anything, no click on webpage is triggererd
Neil, I thought you also would like to see this, as well as bug 1171394 (Win+Linux). I tested the same scenario in user story with findbar and searchbar, and also search fields in devtools - and got the same result. I think that only 'mousedown' event doesn't fire, so 'contextmenu' isn't affected indeed.

I believe that this bug (as well as 1171394) is caused by 1 general issue with "local context menu"
(I don't know how exactly [context="_child"] menus are called)
Status: UNCONFIRMED → NEW
User Story: (updated)
Ever confirmed: true
Flags: needinfo?(enndeakin)
See Also: → 1171394
Duplicate of this bug: 1210203
I confirm that only 'mousedown' fails to fire while 'mouseup' works OK for every mouse button.
Summary: After right click in url bar without selection anything, no click on webpage is triggererd → Mousedown event doesn't fire the first time after context menu was opened in chrome textfield
Seems like on Windows we shouldn't consume the mouse event when a context menu is open.

The essentially means that nsXULPopupManager::Rollup should return false if item->IsContextMenu() is true.
Flags: needinfo?(enndeakin)
> Seems like on Windows we shouldn't consume the mouse event when a context menu is open.
I believe that not only on Windows. In bug 1171394 I mentioned another STR wich prevented 'mousedown' on Ubuntu (I can't test this bug with the same STR because I don't have ubuntu now). The STR itself:
1. Open the following "data:" url or click URL in the form above
>   data:text/html,<html onclick="alert('clicked')" oncontextmenu="alert('contextmenu')">
2. Right-click text in urlbar
3. Place mouse over "Copy" menuitem, press left mouse button, move mouse away from menu, release left mouse button
4. Left-Click page content [I expect, nothing would happen]
So, if nothing happens, it's the same mechanism as in bug 1171394, and should be fixed not only on Win.
The same happens on about:addons AND about:preferences - if I open context menu of input (or if I open drop-down menu by clicking on <menulist>) and then click anywhere - the click doesn't happen.

The same happens in Bookmarks/History sidebar and on about:config with all context menus.
Summary: Mousedown event doesn't fire the first time after context menu was opened in chrome textfield → Mousedown event doesn't fire the first time after context menu was opened on chrome textfield / <tree>s (or menupopup from <menulist> was opened)
See Also: → 1211196
I found the right duplicate.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 358864
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.