Feature request: STR and regression-range pulldowns

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Administration
--
enhancement
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: mhoye, Assigned: dkl)

Tracking

Production

Details

(Reporter)

Description

2 years ago
In order to speed up and improve the outcome of the bug triage process, I'd like to add two pulldowns with four options each. The menus are: "Has regression range" and  "Has STRs", and the states for both would be "unset", "no", "yes" and "irrelevant".

My goal here is to make it trivially easy to see and programmatically surface any work that's required to move a bug forward.
what products should these new fields be visible on?
Component: Bug Creation/Editing → Administration
(Reporter)

Comment 2

2 years ago
Firefox, Core and Toolkit, that's where we're doing most of our community-triage work.
Assignee: nobody → dkl
(Assignee)

Comment 3

2 years ago
Ok I will create the following new custom fields:

"Has Regression Range" (cf_has_regression_range) ["unset", "no", "yes", "irrelevant"]

"Has STR" (cf_has_str) ["unset", "no", "yes", "irrelevant"]

Enabled for the following products: ["Firefox", "Core", "Toolkit"]

Should we expand STR to "Steps to Reproduce"? I will need to created them initially as disabled since we will need a code push to production to set the product visibility. Hopefully this will be first of next week.

dkl
Status: NEW → ASSIGNED
(Assignee)

Comment 4

2 years ago
I have committed the code needed for the next push. We will add the actual custom fields 
during off-peak time before the push.

To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   a85940f..04b55ee  master -> master

dkl
i've created the two fields, but they require configuration (sortkey, etc) and values.
(Assignee)

Comment 6

2 years ago
(In reply to Byron Jones ‹:glob› from comment #5)
> i've created the two fields, but they require configuration (sortkey, etc)
> and values.

So at first I only saw cf_has_regression_range but cf_has_str was not yet created. I tried adding values to cf_has_regression_range and kept getting 500 errors. I deleted the field, cleared memcache and added the cf_has_str field fine and added values to it. I tried adding back cf_has_regression_range (after verifying that it was not present in fielddefs and bz_schema) and now I get the 500 error upon field creation. It shows up in the fielddefs though but I am pretty sure it is borked.

Glob can you create the field tonight when the load is lower as I dont want to keep messing with this during normal peak time if I can help it.

Thanks
dkl
Flags: needinfo?(glob)
not sure what happened -- i didn't get any errors yesterday when creating either field :|

things were in a bit of a mess -- the bugs.cf_has_regression_range column and cf_has_regression_range table existed, but the field wasn't in fielddefs or bz_schema.  i had to manually drop both to get things back on track.

cf_has_regression_range has been created and looks sane now.
Flags: needinfo?(glob)
(Assignee)

Comment 8

2 years ago
Okay. All looks good now. Mhoye, open a new bug if you need further changes.

dkl
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
See Also: → bug 1273185
You need to log in before you can comment on or make changes to this bug.