crash in nvwgf2umx.dll@0x554ab

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

({crash, topcrash-win})

unspecified
Unspecified
Windows 10
crash, topcrash-win
Points:
---

Firefox Tracking Flags

(firefox40 unaffected, firefox41 unaffected, firefox42 unaffected, firefox43+ fixed)

Details

(Whiteboard: [gfx-noted], crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-b36feb8f-e8ac-41bc-b996-c0ba62150916.
=============================================================
Ø 0 	nvwgf2umx.dll 	nvwgf2umx.dll@0x554ab 	
Ø 1 	nvwgf2umx.dll 	nvwgf2umx.dll@0x551cf 	
2 	d3d11.dll 	[thunk]:dxrt11::Direct3DSurface::Release`adjustor{32}' () 	
Ø 3 	nvwgf2umx.dll 	nvwgf2umx.dll@0x551cf 	
4 	dxgi.dll 	GetUnderlyingHwnd(IUnknown*) 	
5 	d3d11.dll 	CUseCountedObject<NOutermost::CDeviceChild>::UCAddUse() 	
6 	d3d11.dll 	CLayeredObjectWithCLS<CTexture2D>::CContainedObject::QueryInterface(_GUID const&, void**) 	
7 	dxgi.dll 	GetUnderlyingHwnd(IUnknown*) 	
8 	d3d11.dll 	CSampler::GetDesc(D3D11_SAMPLER_DESC*) 	
9 	kernel32.dll 	WerpRegisterMemoryBlock 	
10 	dwmapi.dll 	LoadScalingOverrides() 	
11 	d3d11.dll 	CLayeredObjectWithCLS<CTexture2D>::Release() 	
12 	d3d11.dll 	ATL::AtlInternalQueryInterface(void*, ATL::_ATL_INTMAP_ENTRY const*, _GUID const&, void**) 	
13 	d3d11.dll 	NDXGI::CDevice::OpenSharedResource(void*, int, _GUID const&, void**) 	
14 	dxgi.dll 	CDXGISwapChain::EmulateDirtyRectPresentVistaBlt(tagRECT const*, unsigned int, tagRECT*, SUBRESOURCE_BLT_MAP const*, unsigned __int64) 	
15 	dxgi.dll 	GetUnderlyingHwnd(IUnknown*) 	
16 	dxgi.dll 	CDXGISwapChain::PresentImplCore(SPresentArgs const*, unsigned int, unsigned int, unsigned int, tagRECT const*, unsigned int, DXGI_SCROLL_RECT const*, IDXGIResource*, bool&, bool&, bool&) 	
17 	dxgi.dll 	GetUnderlyingHwnd(IUnknown*)
=============================================================
More reports: https://crash-stats.mozilla.org/report/list?product=Firefox&signature=nvwgf2umx.dll%400x554ab

While this crash has reports going back to Firefox 40.0b3, there seems to be a spike in Firefox 43.0a1. I'm reporting this bug to investigate the spike and not necessarily to fix the crash in all branches.

The following analysis focuses on Nightly stats since that's where the spike is.
* Volume: #9 overall @ 1.49%, #4 for Windows 10 
* Platforms: Windows 10 (100%)
* Drivers: NVIDIA 353.62 (100%)
* Devices: GeForce GTX 560 [GF114] (52%), GeForce GT 620 [GF119] (14%)
* URLs: http://www.orange.fr/portail, http://www.spiegel.de/ are top of the list

[Tracking Requested - why for this release]: crash appears to be spiking in Firefox 43.0a1.
OK, let's see what more data we can get.
Whiteboard: [gfx-noted]
tracking-firefox43: ? → +
There are still some crashes with this signature on 42 beta, but only 6 total on 43 for the last week. Milan, is this something your team might look at? Or, might it be related to bug 1189940?
 
If not, I can untrack this since it's not super high volume.
Flags: needinfo?(milan)
I would like it to be the same as bug 1189940 (really, bug 1194335.)  We won't have enough data for a few days, since the uplifts for the fix only went in on 10/19.  Either way, we're not going to look at it until we get the data to either confirm or deny this being a duplicate of the bugs above.
Flags: needinfo?(milan)
Thanks Milan. I just realized this earlier today as I came across bug 1189940. I'll look back in a few days to follow up.
Do we have enough data at this point to know if bug 1189940/bug 1149335 helped?
Looks like only a few crashes now, and none on current branches. I think we can call it fixed for 43 by one of the bugs Milan suggested. 
In fact, fixed across the board seems correct.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox43: affected → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.