If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Pinned tabs not opening on multiple desktops Win10

RESOLVED DUPLICATE of bug 587873

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 587873
2 years ago
2 years ago

People

(Reporter: Colin Howard, Unassigned)

Tracking

40 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

Open a Firefox browser window with a number of "pinned tabs" - the "source" 
Create a second virtual desktop
either drag 'n drop the existing Firefox window to the new desktop or open another Firefox session on the new desktop




Actual results:

If the "pinned tab" window is dragged, the tabs remain pinned
if a new browser window is opened on whichever desktop is sans Firefox NO "pinned tabs" are presented
I haven't checked the effect if tabs are subsequently pinned to a new Firefox browser window with no pre-existing "pinned tabs" - after it is opened, nor the effect of "pinning" new tabs to the "source" browser window on whichever desktop it resides.


Expected results:

Unless it has been specifically designed not to open "pinned tabs" in a second or subsequent browser window then I would expect the "pinned tabs" to be made available.
For the record, Bookmarks are presented in the normal manner with the subsequent browser session(s)

Comment 1

2 years ago
I guess virtual desktop is a native feature of Win 10 that I can't test with Win 7.
Blocks: 1077146
Component: Untriaged → Tabbed Browser

Updated

2 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 2

2 years ago
Pinned tabs in Firefox are per-window. They are not shared between windows in any way, no matter how you organize your desktop (virtual or otherwise).
No longer blocks: 1077146
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587873
You need to log in before you can comment on or make changes to this bug.