Closed Bug 1206047 Opened 6 years ago Closed 6 years ago

[Flame] Share a ringtone to message app, it will automatically exit from message compose screen and go back to Home screen.

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(b2g-master affected)

RESOLVED WORKSFORME
Tracking Status
b2g-master --- affected

People

(Reporter: yue.xia, Unassigned)

References

Details

Attachments

(2 files)

Attached file logcat.txt
[1.Description]:
[Flame KK v2.5][Music NGA]Launch Settings app, share a ringtone to message app, it will automatically exit  from message compose screen and go back to Home screen.
See attachment: AriesKK2.5_video2.3gp & logcat.txt
Found time: 08:17

[2.Testing Steps]: 
1. Navigate to the settings app and select "Sound". 
2. Under the "Tones" category, select "Manage Tones" 
3. Select the "..." button beside a tone. 
4. Select the "Share ringtone" button. 
5. Select the "Messages" button.  

[3.Expected Result]: 
5. Device couldn't exit message compose screen, user could compose and sent the message successfully.

[4.Actual Result]: 
5. Device auto exit message compose screen and go back to Home screen.

[5.Reproduction build]: 
Flame KK v2.5(Affected)
Build ID               20150917150223
Gaia Revision          aede8622d780ec71f766a3ecccbff74c04aaba4e
Gaia Date              2015-09-17 03:40:46
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3929b8fc6c33bf9cc80299743063f0981f545452
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150917.183330
Firmware Date          Thu Sep 17 18:33:40 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
13742
Attached video AriesKK2.5_video2.3gp
Summary: [Flame][Music NGA]Share a ringtone to message app, it will automatically exit from message compose screen and go back to Home screen. → [Flame] Share a ringtone to message app, it will automatically exit from message compose screen and go back to Home screen.
Hi, Shine,

May I know the memory configuration? 319MB, right?
Does it happen on 1G memory configuration?
Flags: needinfo?(yue.xia)
Summary: [Flame] Share a ringtone to message app, it will automatically exit from message compose screen and go back to Home screen. → [Flame][Music NGA]Share a ringtone to message app, it will automatically exit from message compose screen and go back to Home screen.
It should not relate to NGA-Music app.
Summary: [Flame][Music NGA]Share a ringtone to message app, it will automatically exit from message compose screen and go back to Home screen. → [Flame] Share a ringtone to message app, it will automatically exit from message compose screen and go back to Home screen.
Component: Gaia::Music → Gaia::SMS
(In reply to William Hsu [:whsu] from comment #2)
> Hi, Shine,
> 
> May I know the memory configuration? 319MB, right?
> Does it happen on 1G memory configuration?

Hi William,
As you said, the memory configuration of testing device is 319MB. This problem will not happen on 1G memory configuration, so this bug may relate to memory pressure.

Device information: 
Flame v2.5 Build ID: 20150920150205

Thanks.
Flags: needinfo?(yue.xia)
There is a memory/performance issue in the whole system: bug 1204837. We can wait for that bug and see if this still happens.
Depends on: 1204837
See Also: → 1206169
Since bug 1204837 is landed, can we get some help from QA to see if the issue still happens?

Thanks!
Keywords: qawanted
Repro on Builds: 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150901030202
Gaia: c80e8ff25425b007181fd6e3de0500a0358fab37
Gecko: cafb1c90f794a73100a8f0afb9fe3301df0f2bde
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

RESULTS: 
When sharing a ringtone with the Message App and try to compose a message, the app exits to HomeScreen.

NO Repro on Builds: 
Environmental Variables:
Device: Flame 2.5
BuildID: 20151004150211
Gaia: f3d9981dccfa4dfdfcb865d95fdcfb85e4077e1e
Gecko: 3d7532ce81ac571962abc3b99582fe7f5d685192
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

RESULTS: 
When sharing a ringtone to the Message App, the Device DOES NOT auto exit message compose screen and go back to Home screen.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150707180647
Gaia: 86af137c7f4c41c1185e609339002ab47fd6c640
Gecko: ffa83d153080
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


RESULTS: 
When sharing a ringtone to the Message App, the Device DOES NOT auto exit message compose screen and go back to Home screen.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Contact: sleedavid
Oleg please see comment 7.  This issue still occurs.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(azasypkin)
Hi Jayme,
The first result seems should be the "NO Repro on Builds" actually because the build ID and version are older than second test. Could you please confirm that again? Thanks!
Flags: needinfo?(jmercado)
Yeah, per comment 7, it looks like the issue is actually fixed :)

BuildID: 20150707180647 - works fine
BuildID: 20150901030202 - broken (regression :/)
BuildID: 20151004150211 - works fine (fixed!)
Flags: needinfo?(azasypkin)
You are right, I misread the comment.  Resolving this issue as WFM.  Please reopen if this issue occurs again.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(jmercado)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.