favicon.ico not fully rendered

RESOLVED DUPLICATE of bug 119118

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 119118
16 years ago
16 years ago

People

(Reporter: David Haas (gone, not reading mail), Assigned: Stuart Parmenter)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.7+) Gecko/20020116
BuildID:    2002011614

I downloaded a nightly build yesterday and noticed the
favicon.ico's for various sites - like slashdot or netscape -
are suddenly poorly drawn in both the URL bar and the personal
toolbar.

The netscape icon in particular looks like every other line 
was drawn - and the intermediate lines are just the background
gray of the toolbar.

The slashdot icon on my personal toolbar is in a gray square
of a slightly different shade then the toolbar, and also looks
like about every other line was drawn.

This build replaced a 12/31/01 nightly build, which didn't have
this problem.

Reproducible: Always
Steps to Reproduce:
1.Go to www.netscape.com,or www.slashdot.com, or www.cnn.com
2.look at favicon.ico in URL bar.  
3.drag URL to personal toolbar.  

Actual Results:  favicon.ico displayed only half-drawn, or just plain incorrectly

Expected Results:  favicon.ico should be displayed correctly.

Comment 1

16 years ago
Perhaps a screenshot would be helpful. Never seen this.

Comment 2

16 years ago
Created attachment 65465 [details]
Screen Capture...

This screen shot was taken on an OS X system... Mozilla 2002-01-16 (cfm). I
have also seen the same problem on Mach-O builds as well.

On the screen shot (each tab left to right)
This Mozilla Bug, Slashdot.org, ResExcellence, Yahoo, MSN and mozillaZine

Comment 3

16 years ago
Opps... one last note... the bugzilla favicon.ico and the mozillaZine ico
rendered fine... the other 4 had problems.
(Reporter)

Comment 4

16 years ago
Created attachment 65467 [details]
Screenshot of problem

Notice the slashdot, netscape, & cnn icons are odd looking.  
The google icon looks OK.

Comment 5

16 years ago
I think this is the same problem as bug 119919. Certainly I've noticed the
favicon problem and the problem with the text attachment icon appears the same.
I don't know the code well enough to definitely say its the same code and is
therefore a dup, but someone who knows the code better may find the pointer useful.

Comment 6

16 years ago
random guess
Assignee: asa → pavlov
Component: Browser-General → ImageLib
QA Contact: doronr → tpreston

Comment 7

16 years ago
I believe this is a duplicate of 119118, if you don't agree, please reopen

*** This bug has been marked as a duplicate of 119118 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.