Closed Bug 1206282 Opened 4 years ago Closed 4 years ago

[Window Mgmt] Long pressing on one of the 5 buttons on a gallery image will open up a window to copy link.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED WORKSFORME
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: jthomas, Assigned: boris)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(1 file)

Description:
If the user has selected an image in gallery that brings up the 5 buttons (Camera, Edit, Share, Information and Trash) a window will pop up with an option to copy link. 

Repro Steps:

Prereq: Have at least one in image in gallery.

1) Update a Aries to 20150918122511
2) Launch Gallery.
3) Open an image.
4) Long press on one of the 5 buttons below the image.


Actual:
A window opens up with the option to "copy link".

Expected:
It is expected that no window will appear after long pressing one of the available options.

Environmental Variables:
Device: Aries 2.5 Kk
Build ID: 20150918122511
Gaia: 4f22dfecdc046fe5223ee858dd06c11b75884740
Gecko: 37c7812ce0e6d10c7e7182f12e752832835e1d67
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf

Repro frequency: 3/3
See attached: Logcat & Video
Video: https://www.youtube.com/watch?edit=vd&v=CxCaPvPqo1w
This issue DOES occur on the Flame 2.5
Result: New window appears with the option to copy link.

Environmental Variables:
Device: Flame 2.5 Kk Fullflash (319mb)
BuildID: 20150918043022
Gaia: 4f22dfecdc046fe5223ee858dd06c11b75884740
Gecko: 37c7812ce0e6d10c7e7182f12e752832835e1d67
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

-------------------------------------------

This issue does NOT occur on the Flame 2.2
Result: No window appears after long pressing one of the available buttons.

Environmental Variables:
Device: Flame 2.2 Kk Fullflash (319mb)
Build ID: 20150918063047
Gaia: 95950c9d48ad2fc2da7686c2b133b750a99cd3da
Gecko: 38d6133e2416
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]:
Odd menu that is unnecessary.  Let's get a window on this.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20150901182223
Gaia: b75979ec8862bd5799a7c42e938d3f67be38d6ae
Gecko: fb720c90eb49590ba55bf52a8a4826ffff9f528b
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken
Device: Flame
BuildID: 20150901190524
Gaia: b75979ec8862bd5799a7c42e938d3f67be38d6ae
Gecko: 84e10095363e39a609813dfe638e5e3b44f5cc5f
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=fb720c90eb49590ba55bf52a8a4826ffff9f528b&tochange=84e10095363e39a609813dfe638e5e3b44f5cc5f

Caused by changes made in Bug 1121463.
Blocks: 1121463
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Boris This issue seems to have been caused by the changes for bug 1121463.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(boris.chiou)
(In reply to Jayme Mercado [:JMercado] from comment #4)
> Boris This issue seems to have been caused by the changes for bug 1121463. 
> Can you please take a look?

Sure, I will handle these bugs together. Thanks
Flags: needinfo?(boris.chiou)
Assignee: nobody → boris.chiou
Status: NEW → ASSIGNED
Depends on: 1198522
triage: blocking for regression
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
Keywords: qawanted
Add qawanted because Bug 1198522 should fix this problem as well.
This issue is no longer occurring on latest Aries and Flame 2.5. Long pressing on a Gallery menu option does not make a menu appear.

Device: Aries 2.5
BuildID: 20151008110640
Gaia: 4973f57cd8f9a62a95f783a24eac32da2bde99fc
Gecko: a955ea9382afedd66ea0da21fcd2932465168d84
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Flame 2.5 (319MB memory)
BuildID: 20151006030203
Gaia: 60cdaa3d3424db3432dc903e7f9c6c8fa099c06d
Gecko: 3edc8d4a1e198314f5d7ebd2967b85842beef602
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Not sure if we should worksforme this issue or duplicate it.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
(In reply to Pi Wei Cheng [:piwei] from comment #8)
> This issue is no longer occurring on latest Aries and Flame 2.5. Long
> pressing on a Gallery menu option does not make a menu appear.
> 
> Device: Aries 2.5
> BuildID: 20151008110640
> Gaia: 4973f57cd8f9a62a95f783a24eac32da2bde99fc
> Gecko: a955ea9382afedd66ea0da21fcd2932465168d84
> Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
> Version: 44.0a1 (2.5) 
> Firmware Version: D5803_23.1.A.1.28_NCB.ftf
> User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
> 
> Device: Flame 2.5 (319MB memory)
> BuildID: 20151006030203
> Gaia: 60cdaa3d3424db3432dc903e7f9c6c8fa099c06d
> Gecko: 3edc8d4a1e198314f5d7ebd2967b85842beef602
> Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
> Version: 44.0a1 (2.5) 
> Firmware Version: v18Dv4
> User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
> 
> Not sure if we should worksforme this issue or duplicate it.

All I know is these bugs have the same root cause. Maybe duplicating it has more information.
Closing this as WFM.  Please reopen if it occurs again.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Resolution: --- → WORKSFORME
See Also: → 1198522
You need to log in before you can comment on or make changes to this bug.