Double click on title bar should maximize the window instead of opening new tab on OS X

RESOLVED DUPLICATE of bug 1161565

Status

()

RESOLVED DUPLICATE of bug 1161565
3 years ago
3 years ago

People

(Reporter: xidorn, Unassigned)

Tracking

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(Reporter)

Description

3 years ago
On OS X, since Yosemite, the original maximum button becomes full screen button. Now the only way to maximize the window is to double click the title bar of a window.

However, since we draw tab bar in the title bar, only a small part of the title bar can be used to maximize the window.

I suggest we disable "double clicking tab bar to open new tab" on OS X to follow the OS X convention when we draw tabs in the title bar. User can still click the button to open new tab.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1161565
You need to log in before you can comment on or make changes to this bug.