Getting URL of live bookmark

VERIFIED FIXED in Firefox 44

Status

()

Firefox
Bookmarks & History
P3
normal
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Zbynek Burget, Assigned: mak)

Tracking

41 Branch
Firefox 44
Points:
---

Firefox Tracking Flags

(firefox44 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150910171927

Steps to reproduce:

Open Library window (Ctrl+Shift+B).
In the left tree of diretory/bookmark structure make right click to any live bookmark and from context menu select "Copy".


Actual results:

What happened? Nothing!


Expected results:

I expect that I'll have URL of RSS feed in clipboard.
I must go to parent folder, find RSS feed again in tne right part of Library window and there make right click -> Copy to get required URL.
Better solution would be some like properties in the appropriate context menu.
(Best, abandoned, solution was until FF 39 - additional field for URL in feed window)

Updated

3 years ago
Component: Untriaged → Bookmarks & History

Comment 1

3 years ago
It's probably because the location fied of RSS feeds has been removed (see bug 1203341), then now, when you use the "Copy" entry in the context menu of a live bookmark, Firefox copies nothing.
In addition, the RSS icon for the folder has been removed, so it's impossible to make the difference between a live bookmark and a bookmark in the library.

Bad design IMHO, and really a regression for the user. Maybe the code is simpler and but it has broken so many user features.

Comment 2

3 years ago
(Build ID 20150921073455)

from Browser Console,
>ReferenceError: can't access lexical declaration `node' before initialization
> PlacesUtils.jsm:580:13
>NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "can't access lexical declaration `node' before initialization" {file: "resource://gre/modules/PlacesUtils.jsm" line: 580}]'[JavaScript Error: "can't access lexical declaration `node' before initialization" {file: "resource://gre/modules/PlacesUtils.jsm" line: 580}]' when calling method: [nsIController::doCommand] controller.js:1724:0

Look PlacesUtils.jsm:580:13.
>        let node = PlacesUtils.getFolderContents(node.itemId, false, true).root;
(Assignee)

Comment 3

3 years ago
(In reply to Loic from comment #1)
> It's probably because the location fied of RSS feeds has been removed (see
> bug 1203341), then now, when you use the "Copy" entry in the context menu of
> a live bookmark, Firefox copies nothing.

No, copy should copy the feed uri, if it doesn't it's a bug.

> In addition, the RSS icon for the folder has been removed, so it's
> impossible to make the difference between a live bookmark and a bookmark in
> the library.

And this is another bug, pretty sure it's filed already.

> Bad design IMHO, and really a regression for the user. Maybe the code is
> simpler and but it has broken so many user features.

you are mixing up bugs with decisions, please don't.
(Assignee)

Comment 4

3 years ago
(In reply to atlanto from comment #2)
> (Build ID 20150921073455)
> 
> from Browser Console,
> >ReferenceError: can't access lexical declaration `node' before initialization
> > PlacesUtils.jsm:580:13
> >NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "can't access lexical declaration `node' before initialization" {file: "resource://gre/modules/PlacesUtils.jsm" line: 580}]'[JavaScript Error: "can't access lexical declaration `node' before initialization" {file: "resource://gre/modules/PlacesUtils.jsm" line: 580}]' when calling method: [nsIController::doCommand] controller.js:1724:0
> 
> Look PlacesUtils.jsm:580:13.
> >        let node = PlacesUtils.getFolderContents(node.itemId, false, true).root;

This is a bug in the code, we cannot shadow the node argument with a local node variable. I don't know if just fixing this will fix the bug, but it's something to fix regardless.
Assignee: nobody → mak77
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

2 years ago
Priority: -- → P3
(Assignee)

Comment 5

2 years ago
Created attachment 8673716 [details] [diff] [review]
1206488.diff
Attachment #8673716 - Flags: review?(gijskruitbosch+bugs)

Comment 6

2 years ago
Comment on attachment 8673716 [details] [diff] [review]
1206488.diff

Review of attachment 8673716 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me
Attachment #8673716 - Flags: review?(gijskruitbosch+bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/6eadb1d83039
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox44: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 44
QA Whiteboard: [good first verify]

Comment 9

2 years ago
I have reproduced this bug with Firefox Nightly 43.0a1(Build ID-20150920030217)on
windows 7(64 bit)

Verified as fixed with Latest Firefox Beta 44.0b7 (Build ID: 20160107144911)
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
[testday-20160108]

Updated

2 years ago
Status: RESOLVED → VERIFIED
status-firefox44: fixed → verified
You need to log in before you can comment on or make changes to this bug.