Wrong default search engine favicon displayed in BrowserSearch screen

RESOLVED DUPLICATE of bug 1206628

Status

()

RESOLVED DUPLICATE of bug 1206628
3 years ago
3 years ago

People

(Reporter: TeoVermesan, Assigned: psd)

Tracking

43 Branch
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 unaffected, firefox44 affected, fennec44+)

Details

(Reporter)

Description

3 years ago
Tested with:
Device: Moto X (Android 4.4)
Build: Firefox for Android 43.0a1 (2015-09-20)

Steps to reproduce:
(google is the default search engine)
1. Go to Settings -> Customize -> Search 
2. Tap on "Twitter" and select "Set as Default"
3. Open a new tab and tap "test" in the URL Bar

Expected results:
- the word typed at step 3 is displayed with the twitter search engine favicon in BrowserSearch screen 
- search engine works as expected and displays the correct twitter result.

Actual results:
- the word typed at step 3 is displayed with google search engine favicon but the search engine works ok and displays the correct twitter result.
- going once again to Settings -> Customize -> Search and select "Bing" as default search engine and write something in the URL Bar, the word is displayed with "Twitter" favicon, but the search is done through "Bing".

Note:
-good build: 17-09
-bad build: 18-09
pushlog:http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e7d613b3bcfe1e865378bfac37de64560d1234ec&tochange=11dc79e232110ba6de5179e46dfbda77b52a88c3
tracking-fennec: --- → ?
Like bug 1206628, I think this is a pre-existing bug uncovered by bug 1186683, which no longer creates BrowserSearch (and thus requests the search engines) each time it is shown. Some possibilities:
  1) We don't update the search engines in Java (i.e. the UI) but when we run a search via the search engine list in Gecko, it uses a positional element so the search occurs as expected even though the UI is not updated to reflect that
  2) We don't correctly update the favicon when the search engine list is updated.

Given bug 1206628, I'd say #1 sounds more correct.
Depends on: 1186683
Assignee: nobody → michael.l.comella
tracking-fennec: ? → 43+
via IRC – Prabhjyot is interested in fixing the regressions of bug 1186683.
Assignee: michael.l.comella → prabhjyotsingh95
We backed out bug 1186683 from 43.
tracking-fennec: 43+ → 44+
status-firefox43: affected → unaffected
status-firefox44: --- → affected
Blocks: 1086952
Prabhjyot, any updates on these regressions? Do you still think finishing them by merge (November 2nd) is reasonable?
Flags: needinfo?(prabhjyotsingh95)
(Assignee)

Comment 5

3 years ago
As discussed on IRC, I have uploaded a patch for bug 1206628 which also fixes this. I do, still think that we will be able to finish these by merge!
Flags: needinfo?(prabhjyotsingh95)
(Assignee)

Comment 6

3 years ago
fixed by bug 1206628
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1206628
You need to log in before you can comment on or make changes to this bug.