Closed Bug 1206701 Opened 4 years ago Closed 4 years ago

Unable to perfom a Video or Audio only conversation via FxA

Categories

(Hello (Loop) :: Client, defect, P1)

defect

Tracking

(firefox43+ verified, firefox44+ verified)

VERIFIED FIXED
mozilla44
Tracking Status
firefox43 + verified
firefox44 + verified

People

(Reporter: adalucinet, Assigned: standard8)

Details

(Keywords: regression)

Attachments

(1 file)

Reproducible with latest 43.0a1 (from 2015-09-20)
Affected platforms: Ubuntu 14.04 32-bit, Mac OS X 10.10.5, Windows 7 64-bit, Windows 10 32-bit 

Steps to reproduce: 
1. Launch Firefox.
2. Click the Hello button from the toolbar and Sign In to FxA.
3. Via the Contact Options Panel select Audio Conversation or Video Conversation. 

Expected behavior: Audio/Video only conversation is successfully performed.
Actual results: Unable to perform an Audio/Video only call.

Addition notes:
1. Screencast: https://goo.gl/6Bzdrc
2. Works with Nightly 2015-07-21 - will investigate further.
Assignee: nobody → standard8
Rank: 18
Keywords: regression
Priority: -- → P1
I suspect when I re-added these items, I'd incorrectly left the <i> tags in place (which were previously used for icons we now no longer have). I don't know why its showing up now, nor do I quite understand what's going on, but removing them seems to fix the issue and as they're obsolete, it seems a good thing to do anyway ;-)
Attachment #8663691 - Flags: review?(edilee)
Comment on attachment 8663691 [details] [diff] [review]
Fix the contact menu buttons on Loop's panel so that audio and video conversations can be selected properly.

Patch works for me. Although somewhat concerning that the tests didn't catch this:

https://dxr.mozilla.org/mozilla-central/source/browser/components/loop/test/desktop-local/contacts_test.js#685

There's several tests that "click" on the menu item. Some basic testing without the patch shows that onClick isn't handled when clicking on the text when <i> is there, but even with <i>, if you click in the whitespace at the start/end of the text, the menu item /is/ triggered.

Not sure if it's worth updating the test to "click" the text instead of clicking the menu.
Attachment #8663691 - Flags: review?(edilee) → review+
(In reply to Ed Lee :Mardak from comment #2)
> Although somewhat concerning that the tests didn't catch
> this:
> 
> https://dxr.mozilla.org/mozilla-central/source/browser/components/loop/test/
> desktop-local/contacts_test.js#685
> 
> There's several tests that "click" on the menu item. Some basic testing
> without the patch shows that onClick isn't handled when clicking on the text
> when <i> is there, but even with <i>, if you click in the whitespace at the
> start/end of the text, the menu item /is/ triggered.
> 
> Not sure if it's worth updating the test to "click" the text instead of
> clicking the menu.

I think we're always going to run this risk on these sorts of items - even if I could specifically get the text item, the <i> could still have been inserted and not been detected by the test.
https://hg.mozilla.org/mozilla-central/rev/f9451efeca2f
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Comment on attachment 8663691 [details] [diff] [review]
Fix the contact menu buttons on Loop's panel so that audio and video conversations can be selected properly.

Approval Request Comment
[Feature/regressing bug #]: UX Refresh for Loop
[User impact if declined]: Can't make a direct call to a contact using the menu options for video or audio.
[Describe test coverage new/current, TreeHerder]: Landed in m-c. Code has unit tests, but difficult to cover this exact case with automated tests.
[Risks and why]: Low, simple fix to code.
[String/UUID change made/needed]: None
Attachment #8663691 - Flags: approval-mozilla-aurora?
Comment on attachment 8663691 [details] [diff] [review]
Fix the contact menu buttons on Loop's panel so that audio and video conversations can be selected properly.

Looks good on m-c, let's uplift this.
Attachment #8663691 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed with latest 43.0a2 Developer Edition and 44.0a1 Nightly (both from 2015-09-29), across platforms [1].

[1] Windows 7 64-bit, Ubuntu 14.04 64-bit and Mac OS X 10.10.4
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.