Closed Bug 1207042 Opened 5 years ago Closed 3 years ago

TEST-UNEXPECTED-ERROR | test_fallback_update.py TestFallbackUpdate.test_update | NoSuchWindowException: NoSuchWindowException: Unable to locate window: [1|3]

Categories

(Testing :: Firefox UI Tests, defect)

Version 3
defect
Not set
normal

Tracking

(firefox43 affected, firefox44 affected)

RESOLVED DUPLICATE of bug 1375405
Tracking Status
firefox43 --- affected
firefox44 --- affected

People

(Reporter: whimboo, Unassigned)

References

Details

This failure occurs when trying to restart Firefox through Marionette. I  cannot reproduce it locally so far but a couple of tests for Nightly have been failed.

15:43:29 Traceback (most recent call last):
15:43:29   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\marionette\marionette_test.py", line 296, in run
15:43:29     testMethod()
15:43:29   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\firefox_ui_tests\update\fallback\test_fallback_update.py", line 28, in test_update
15:43:29     self._test_update()
15:43:29   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\firefox_ui_tests\update\fallback\test_fallback_update.py", line 22, in _test_update
15:43:29     self.download_and_apply_forced_update()
15:43:29   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\firefox_ui_harness\testcases\update.py", line 205, in download_and_apply_forced_update
15:43:29     self.restart()
15:43:29   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\firefox_ui_harness\testcases\base.py", line 39, in restart
15:43:29     self.browser = self.windows.switch_to(lambda win: type(win) is BrowserWindow)
15:43:29   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\firefox_puppeteer\ui\windows.py", line 168, in switch_to
15:43:29     self.marionette.switch_to_window(handle)
15:43:29   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\marionette_driver\marionette.py", line 1237, in switch_to_window
15:43:29     self._send_message("switchToWindow", {"name": window_id})
15:43:29   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\marionette_driver\decorators.py", line 36, in _
15:43:29     return func(*args, **kwargs)
15:43:29   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\marionette_driver\marionette.py", line 711, in _send_message
15:43:29     self._handle_error(resp)
15:43:29   File "c:\jenkins\workspace\mozilla-aurora_update\venv\lib\site-packages\marionette_driver\marionette.py", line 752, in _handle_error
15:43:29     raise errors.lookup(error)(message, stacktrace=stacktrace)
15:43:29 NoSuchWindowException: NoSuchWindowException: Unable to locate window: 1
Those failures started recently for mozilla-central and mozilla-aurora without any reasonable changes on our side. I wonder if those are somekind of regressions from Marionette server changes on those affected branches.

The underlying issue for those messages is most likely bug 1207125 which returns a non-related reply for the sent command.
Depends on: 1207125
So actually those failures started with the first Aurora build after the merge on Monday which means that it might have been a change landed earlier but maybe was not active on mozilla-central. Also it looks like that only Win7 32bit VMs are affected so far.
I won't spend more time on it right now given that I cannot reproduce it locally and it doesn't happen that often. If we have a spike I will check again.
Product: Mozilla QA → Testing
It's not reproducible for me and
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1375405
You need to log in before you can comment on or make changes to this bug.