[Control Center] Incorrect doorhanger placement for the Identity Extended Subview

RESOLVED FIXED

Status

()

Toolkit
XUL Widgets
P3
normal
RESOLVED FIXED
2 years ago
7 months ago

People

(Reporter: cornel_ionce, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 affected, firefox42 affected, firefox43 affected, firefox44 affected)

Details

(Whiteboard: [fxprivacy])

Attachments

(1 attachment)

Reproduced on Windows 10 64-bit with:
* 42.0 beta 1
* latest 43.0a2 Aurora
* latest 44.0a1 Nightly

STR:
1. Open Firefox.
2. Navigate to https://timtaubert.de/ 
3. Move the broswer close to the bottom of the screen
4. Click on the site identity panel and then on the ">" button.

Expected Results:
The subview is correctly displayed.

Actual Results:
The doorhanger is missplaced, displayed at the top of the pop`up instead of bottom.

Screenshot: http://i.imgur.com/qvoQ3Wl.jpg

Updated

2 years ago
Whiteboard: [fxprivacy] [triage]
This looks like an issue with the XUL panel.  Does this happen on other versions of Windows?
Flags: needinfo?(cornel.ionce)

Updated

2 years ago
Blocks: 1188565
It seems that this is reproducing across platform.

I've tested on Windows 7 64-bit, Windows 8 32-bit, Ubuntu 12.04 32-bit and Mac OS X 10.9.5 and they are all affected.
Flags: needinfo?(cornel.ionce)
OS: Windows 10 → All
OK I see it now, thanks.  The panel arrow never gets re-anchored when switching into the subview if the main view opened in the bottom at first.  If you get it to open the main view above the browser in the first place than the arrow is correct.
Looks like this started happening after 41
status-firefox41: --- → affected
status-firefox42: --- → affected
status-firefox43: --- → affected
Component: General → XUL Widgets
Product: Firefox → Toolkit

Updated

2 years ago
Priority: -- → P3
Whiteboard: [fxprivacy] [triage] → [fxprivacy]
It looks like this is an issue with the XUL panel where the positioning is being updated but the arrow icon that anchors it to the ID block isn't moving.
Matt, do you think this is a duplicate of Bug 1188400?
Flags: needinfo?(MattN+bmo)
Does the patch in bug 1206133 fix this?
Created attachment 8667491 [details]
arrow-up.png

(In reply to Neil Deakin from comment #7)
> Does the patch in bug 1206133 fix this?

No, tested with the patch applied locally and the arrow is still showing up on the top side of Control Center after expanding the subview.  To make sure that the subview is taller than the main view I've set this in the CSS:

#identity-popup-permissions-content {
  display: none;
}
See Also: → bug 1210328
I updated the patch in bug 1206133 and it should address this case.

Updated

2 years ago
Blocks: 1216897

Updated

2 years ago
No longer blocks: 1188565
Depends on: 1206133
Flags: needinfo?(MattN+bmo)
I just tested and this is now fixed by the patch in bug 1206133.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED

Updated

7 months ago
Iteration: --- → 52.3 - Nov 14
You need to log in before you can comment on or make changes to this bug.