Closed Bug 1207579 Opened 5 years ago Closed 3 years ago

crash in java.lang.IllegalAccessException: class org.mozilla.gecko.home.PinSiteDialog is not accessible from class android.support.v4.app.Fragment at java.lang.Class.newInstance(Class.java)

Categories

(Firefox for Android :: General, defect, critical)

43 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox55 --- wontfix
firefox56 ? fixed
firefox57 --- fixed

People

(Reporter: ioana.chiorean, Assigned: mkaply)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-3b5a882e-9aed-4820-956f-c60152150923.
=============================================================
I am not able to reproduce this with clear steps, but I met it several times in a few hours. Till you kill the app it crashes constantly. 
I looked in the reports and seems that occurs on several devices.
OS: Unspecified → Android
Hardware: Unspecified → ARM
Version: unspecified → Trunk
Version: Trunk → Firefox 43
Tracking for 43. Looks like 41 and 40.0.3 are also affected.
Crash Signature: [@ java.lang.IllegalAccessException: class org.mozilla.gecko.home.PinSiteDialog is not accessible from class android.support.v4.app.Fragment at java.lang.Class.newInstance(Class.java)] → [@ java.lang.IllegalAccessException: class org.mozilla.gecko.home.PinSiteDialog is not accessible from class android.support.v4.app.Fragment at java.lang.Class.newInstance(Class.java)] [@ java.lang.IllegalAccessException: class org.mozilla.gecko.home.Pin…
Only a couple of crashes on 43 beta; this seems to be a crash that shows up more once we get to the release channel.
332 crashes on 42 in the last week (most of them startup crashes).  
Snorp can you help us find an owner for this bug? Or if you think we will end up wontfixing for 43, can you mark it as such? Thanks.
Flags: needinfo?(snorp)
Assignee: nobody → margaret.leibovic
Flags: needinfo?(snorp)
Currently this only has a couple of crashes on 43 beta 6 and 7. It was a topcrash for 42 though. I'm going to keep tracking this in case it gets worse on release. Maybe it's fixed, maybe it's a different user population.
199 crashes for 43.0 in the last week still looking like startup crashes.  I can't tell how serious that is. 

Too late to fix in 43 though. 
This may pop up on 44 once it hits release (in the same pattern).
I only see 7 instances of this in the past 28 days. I don't think this needs to be tracked for FF44 as it is not a top 20 crasher. If the data changes or there is a spike, please renominate.
Assignee: margaret.leibovic → nobody
Taking
Assignee: nobody → mozilla
Comment on attachment 8893547 [details]
Bug 1207579 - Make PinSiteDialog public to ensure it can be accessed from v4.app.fragment

https://reviewboard.mozilla.org/r/164622/#review169974

::: mobile/android/base/java/org/mozilla/gecko/home/PinSiteDialog.java:40
(Diff revision 1)
>  import android.widget.ListView;
>  
>  /**
>   * Dialog fragment that displays frecency search results, for pinning a site, in a GridView.
>   */
>  class PinSiteDialog extends DialogFragment {

The class needs to be public, not the constructor.
Attachment #8893547 - Flags: review?(snorp) → review-
Comment on attachment 8893547 [details]
Bug 1207579 - Make PinSiteDialog public to ensure it can be accessed from v4.app.fragment

https://reviewboard.mozilla.org/r/164622/#review170114
Attachment #8893547 - Flags: review?(snorp) → review+
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/044a5b82b056
Make PinSiteDialog public to ensure it can be accessed from v4.app.fragment r=snorp
[Tracking Requested - why for this release]: We had a partner find this in their testing of a preload of Fennec.

Since it's such a straightforward fix, I'd like to take it in 56.
https://hg.mozilla.org/mozilla-central/rev/044a5b82b056
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Please nominate it for Beta approval then :)
Comment on attachment 8893547 [details]
Bug 1207579 - Make PinSiteDialog public to ensure it can be accessed from v4.app.fragment

Approval Request Comment
[Feature/Bug causing the regression]: N/A
[User impact if declined]: Occasional crash
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Not easily reproducible
[Needs manual test from QE? If yes, steps to reproduce]: Not easily reproducible
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Change from private to public. No core code change.
[String changes made/needed]:
Flags: needinfo?(mozilla)
Attachment #8893547 - Flags: approval-mozilla-beta?
Comment on attachment 8893547 [details]
Bug 1207579 - Make PinSiteDialog public to ensure it can be accessed from v4.app.fragment

A simple change. Beta56+. Should be in 56 beta 2.
Attachment #8893547 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.