Do special build-timing builds

RESOLVED DUPLICATE of bug 1380893

Status

RESOLVED DUPLICATE of bug 1380893
3 years ago
5 months ago

People

(Reporter: ted, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

We've been talking about tracking build time and being able to alert on regressions etc, but that's kind of hard because of how variable the timings are. Things like having a fresh objdir vs. a clobber build can change timing dramatically.

catlee suggested doing special builds that we could use for measuring timing. We floated the idea of maybe doing a clobber build since that removes the issues with dep builds (but we might also need to disable things like sccache to get honest timing). We might want to do a no-op dep build on top of that clobber to get timing for that, so we could track if someone regressed no-op time (by causing something to build all the time or something like that).
Component: General Automation → Build Config
Product: Release Engineering → Firefox
QA Contact: catlee
I'm not fully convinced we need this anymore. The build timings data we have on perfherder is pretty good these days.
I thought about saying that too. But your blurb about "disable things like sccache to get honest timings" and measuring things like a no-op dep build is still relevant and data worth having, IMO.
triaging

gps: Don't we have builds that run w/o sccache now to get relevant timings?  Can this bug be closed?
Component: Build Config → General
Flags: needinfo?(gps)
Product: Firefox → Firefox Build System
Yes, that was bug 1380893. Apparently we forgot about this bug!
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Flags: needinfo?(gps)
Resolution: --- → DUPLICATE
Duplicate of bug: 1380893
You need to log in before you can comment on or make changes to this bug.