UI repainting seriously wrong before going fullscreen

RESOLVED DUPLICATE of bug 1137009

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1137009
3 years ago
3 years ago

People

(Reporter: Cam, Unassigned)

Tracking

42 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8664970 [details]
Screen Shot of ui hang.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150921004016

Steps to reproduce:

Start Firefox
go fullscreen
quit firefox while fullscreen
restart Firefox


Actual results:

Firefox paints the ui properly for a few miliseconds then stops even if the ui is unusable, and doesn't repaint when interacted with until I enter fullscreen.

Leaving fullscreen does not reintroduce the issue. And technically the UI is still responsive, but you can't see what you are clicking on.


Expected results:

Firefox ui is painted as usual.
(Reporter)

Updated

3 years ago
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64

Updated

3 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
Does this bug still exist in Nightly?

Comment 2

3 years ago
On Windows, there is a similar behaviour, after restarting Firefox previously set in FS mode, Firefox doesn't paint the content page (blank page) during a few ms when reaching FS.
I expect all issues like this (opening window or quiting the browser when in fullscreen causes the UI be broken) should be fixed by my patches in bug 1137009.
Depends on: 1137009
(Reporter)

Comment 4

3 years ago
Bug 1137009 says it's resolved fixed, but this is still occurring in Aurora/FFDE 43.a2. Has the patch only made it to nightly or is it in aurora too? Because I don't see the issue in nightly (though I am using a new profile in nightly).
That fix is currently only in Nightly, but I've requested an uplift to Aurora, which haven't been granted yet.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Whiteboard: [gfx-noted]
Duplicate of bug: 1137009
You need to log in before you can comment on or make changes to this bug.