Closed Bug 1207985 Opened 6 years ago Closed 6 years ago

[music][nga] On Music NGA screen, tap two phones together, the test phone can't enter NFC shrinking screen.

Categories

(Firefox OS Graveyard :: Gaia::Music, defect, P2)

ARM
Gonk (Firefox OS)

Tracking

(blocking-b2g:2.5+, b2g-master affected)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-master --- affected

People

(Reporter: yue.xia, Assigned: squib)

References

(Blocks 1 open bug)

Details

(Whiteboard: [2.5-aries-test-run-3])

Attachments

(3 files)

[1.Description]:
[Flame KK v2.5][Music][NGA]Launch Music NGA app on test phone, play a song, tap two phones together, the test phone only have a vibration, but it can't enter NFC shrinking screen.
See attachment: logcat_FlameKK2.5_1637.txt & FlameKK2.5_video1.3gp
Found time: 16:37


[2.Testing Steps]: 
1. Go to "Settings", Switch on NFC on both phones. 
2. Go to "Settings", Switch on Bluetooth on both phones. 
3. Go to "Music NGA" on test phone, select a song 
4. Tap test phone and another phone together 


[3.Expected Result]: 
4. The test phone should enter NFC shrinking screen.

[4.Actual Result]: 
4. The test phone only has a vibration, but it can't enter NFC shrinking screen.

[5.Reproduction build]: 
Device: FlameKK_V2.5 (319MB) [Affected]
Build ID               20150923150203
Gaia Revision          8472f0c736660072799aaae60e4b6001a6aaceb4
Gaia Date              2015-09-23 10:29:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4a46de29431baa621d98d8f1168e43297ce1a916
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150923.184655
Firmware Date          Wed Sep 23 18:47:17 EDT 2015
Base Image     v18d v4
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
13820

[8.Note]:
On flame KK 2.5 device, the Old Music app can enter shrinking screen normally.
Attached video FlameKK2.5_video1.3gp
[Blocking Requested - why for this release]:
Broken basic function
blocking-b2g: --- → 2.5?
QA Whiteboard: [COM=NFC]
Blocks 2.5. Functionality is broken.
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
Jim, 

Can you take a look at this? Perhaps this was missed in the new app. 

Thanks
Hema
Flags: needinfo?(squibblyflabbetydoo)
Yeah, the NFC stuff got lost in the migration.
Flags: needinfo?(squibblyflabbetydoo)
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Comment on attachment 8673962 [details] [review]
[gaia] jimporter:music-nga-nfc > mozilla-b2g:master

Ok, this should do basically the same thing as OGA.
Attachment #8673962 - Flags: review?(jdarcangelo)
Comment on attachment 8673962 [details] [review]
[gaia] jimporter:music-nga-nfc > mozilla-b2g:master

Looks good! Just address my one comment on the PR regarding breaking out the lazy-loading of the NFC module into a separate function to match the existing conventions. My other comment on the PR is invalid since we should continue using `client.method()` to talk between app.js and endpoint.js if we can. This will help us break out the endpoint for SW much easier later on.
Attachment #8673962 - Flags: review?(jdarcangelo) → review+
Whiteboard: [2.5-aries-test-run-3]
Summary: [Flame][Music][NGA]On Music NGA screen, tap two phones together, the test phone can't enter NFC shrinking screen. → [music][nga] On Music NGA screen, tap two phones together, the test phone can't enter NFC shrinking screen.
Landed: https://github.com/mozilla-b2g/gaia/commit/16eaf7555b77f779d8a90569caed08dce701c24a
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Verified on

[Flame]
Build ID               20151022150207
Gaia Revision          29ce8ec8606e59f582375234440812b046346513
Gaia Date              2015-10-22 05:31:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/76bd0c01d72e64ca4f261ffdb2652a91f961e930
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151022.185000
Firmware Date          Thu Oct 22 18:50:13 EDT 2015
Bootloader             L1TC000118D0

[Aries]
Build ID               20151023005002
Gaia Revision          29ce8ec8606e59f582375234440812b046346513
Gaia Date              2015-10-22 05:31:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1f03a14106e59280761ac53904340f389674337f
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151023.001128
Firmware Date          Fri Oct 23 00:11:35 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.