Crash expanding IMAP mail account before start page finishes loading

VERIFIED WORKSFORME

Status

P3
major
VERIFIED WORKSFORME
20 years ago
11 years ago

People

(Reporter: lchiang, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PR1])

(Reporter)

Description

20 years ago
Crash expanding IMAP mail account before start page finishes loading

Win32 8/16/99 build - M9

1) Start messenger
2) Start page has not finished loading yet in the message pane
3) Expand mail account by clicking on the + sign next to the account name
4) Select IMAP Inbox

--> Crash occurs.  Stack trace below (incident ID 12574107)

Call Stack:    (Signature = nsImapProtocol::ProcessCurrentURL e73b3bf2)
   nsImapProtocol::ProcessCurrentURL
[d:\builds\seamonkey\mozilla\mailnews\imap\src\nsImapProtocol.cpp, line 818]
   nsImapProtocol::ImapThreadMainLoop
[d:\builds\seamonkey\mozilla\mailnews\imap\src\nsImapProtocol.cpp, line 678]
   nsImapProtocol::ImapThreadMain
[d:\builds\seamonkey\mozilla\mailnews\imap\src\nsImapProtocol.cpp, line 538]
   _PR_NativeRunThread
[pruthr.c, line 401]
   MSVCRT.dll + 0x3e33 (0x78003e33)
   KERNEL32.dll + 0x4f3e (0x77f04f3e)
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

20 years ago
I was not able to recreate this, but I'll keep trying.
(Reporter)

Comment 2

20 years ago
Does the file and line number in the talkback report tell you anything useful?
(Reporter)

Comment 3

20 years ago
Just a fyi - I got this with the 8/20 M9 build.  Talkback 12723620.  Same stack
trace.

This appears to happen the first time I install a release build.
(Reporter)

Comment 4

20 years ago
I wonder if there is any way to cause the start page to load really slowly so
that you can hopefully :-) reproduce this crash.
(Assignee)

Updated

20 years ago
Target Milestone: M11
(Assignee)

Comment 5

20 years ago
I think Phil just saw this after getting a profile up for the first time. It
had nothing to do with the start page loading, since he had been fooling around
with newsgroups for a while before expanding the imap server. His m_channel was
null, which means it was not created correctly. I'll have to try it with a brand
new profile.

Comment 6

20 years ago
This happened to me again today, reusing the profile I created yesterday.
(Reporter)

Comment 7

20 years ago
Phil - was this with a new build?  I seem to get this crash the first time I
start Messenger and follow my steps using a newly downloaded build (same profile
though).

Updated

20 years ago
Whiteboard: [PR1]

Comment 8

20 years ago
Crashers need to be fixed for PR1, so I added a note to the Status Whiteboard
(Assignee)

Comment 9

20 years ago
this still works for me, and I've done a lot of new installs. Lisa, can you
still reproduce this?
(Reporter)

Comment 10

20 years ago
I will try this on Friday for you.
(Reporter)

Updated

20 years ago
Blocks: 11091
(Reporter)

Comment 11

20 years ago
(target milestone is M11 or M12 - add to mail beta tracking bug)
(Assignee)

Comment 12

20 years ago
Any status on this one? I haven't heard of anyone having this problem in a long
time.
(Reporter)

Comment 13

20 years ago
I'm sorry.  I neglected this bug.  Go ahead and mark it worksforme.  I have not
seen this bug and can't reproduce it at this time.
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 14

20 years ago
thanks, Lisa.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.