bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Bookmarks toolbar's 'new folder' function creates nameless folder, renames the last one instead

RESOLVED DUPLICATE of bug 1206376

Status

()

Firefox
Bookmarks & History
P2
critical
RESOLVED DUPLICATE of bug 1206376
3 years ago
3 years ago

People

(Reporter: peaceeker, Unassigned)

Tracking

40 Branch
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150917150946

Steps to reproduce:

I have spotted a huge problem on Firefox since yesterday, on BOTH of my computers. One has the 40.0.3 version, while this one has the 41.0 version. I guess it's the same mistake. This is why I classify this issue in the "40 Branch". 
Here's what I have done:
- tried to create a folder from the Bookmarks Toolbar: (1) right-click and (2) click 'new folder'
- a form appears, asking me to rename 'New Folder'. So do I.


Actual results:

- A new folder has been created. 
- Sadly, it is still called 'New Folder' instead of the name I gave.
- Worse, I happen to find this new name ... having erased and replaced the name of the last folder in the toolbar!
( all of this is bugging, given that I don't always recall how I named the last folder )
- The renaming function seems to be fine. I can therefore rename 'New Folder' by typing again, in the renaming form, its name, as well as renaming the last folder with the name I recollect. 
- all in all this very bugging bug necessitates two renamings. 
- it works fine through the Control+J Bookmark manager.


Expected results:

- a new folder should have been created with the name I gave in the form, while keeping untouched the name of the last folder.
(Reporter)

Updated

3 years ago
Summary: Bookmarks toolbar 'new folder' function, creates nameless folder and renames the last one instead → Bookmarks toolbar's 'new folder' function creates nameless folder, renames the last one instead
(Reporter)

Updated

3 years ago
Severity: normal → critical
Component: Untriaged → Bookmarks & History
OS: Unspecified → Windows 7
Priority: -- → P2
Hardware: Unspecified → All

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1206376
You need to log in before you can comment on or make changes to this bug.