Closed Bug 1208443 Opened 9 years ago Closed 2 years ago

Strings pasted into urlbar are doubled after opening new tab (if Debugger was opened in Browser Toolbox)

Categories

(DevTools :: Framework, defect)

defect
Not set
normal

Tracking

(firefox44 affected)

RESOLVED WORKSFORME
Tracking Status
firefox44 --- affected

People

(Reporter: arni2033, Unassigned)

References

(Blocks 1 open bug)

Details

STR:   (Win7_64, Nightly 44, 32bit, ID 20150924030231, new profile, safe mode)
0. Make sure you have some text copied to clipboard, e.g. "They're taking your beta-testers to Isengard"
1. Open Firefox
2. Press Ctrl+Alt+Shift+I to open Browser Toolbox (make sure you have all those stuff enabled)
3. Click Debugger tab in the Browser Toolbox
4. Switch back to Firefox window
5. Press Ctrl+N to open new window
6. Focus location bar and press Ctrl+V to paste the text from clipboard

Result:       Text is doubled. Actually sometimes I see (when firefox lags and does everything slowly)
              that when I press Ctrl+V, the text is pasted OK, but after 2-3 seconds the same text
              is pasted the second time w/o any input. Maybe it's a special case of some major bug

Expectations: Text should be pasted 1 time
Has STR: --- → yes
Product: Firefox → DevTools

I can't reproduce this, closing.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.