Closed Bug 1208489 Opened 4 years ago Closed 3 years ago

Notifications can be deformed and they leave useless white rectangle in content area after closing (reproducible on clear profile)

Categories

(DevTools :: Framework, defect)

defect
Not set

Tracking

(firefox44 affected, firefox48 wontfix, firefox49 fixed, firefox50 verified)

VERIFIED FIXED
Firefox 50
Tracking Status
firefox44 --- affected
firefox48 --- wontfix
firefox49 --- fixed
firefox50 --- verified

People

(Reporter: arni2033, Assigned: Gijs)

References

Details

Attachments

(4 files)

STR:   (Win7_64, Nightly 44, 32bit, ID 20150924030231, new profile, safe mode)
1. Open attached html page   [notification about blocked window will appear]
2. Open devtools (Ctrl+Shift+I)
3. Increase devtools frame's height as much as you can (without detaching them to separate window).
4. Close devtools (Ctrl+Shift+I)
5. Close the notification about blocked window

Result:       Notification (1) deforms after Step 3 and   (2) leaves empty area after Step 5.
Expectations: Notifications (1) shouldn't deform and   (2) should close normally

Please split this into 2 bugs if needed. Also, please change the title to better reflect that it's 100% reproducible for everyone, not just me with my (theoretically) "weird setup"
It applies only to notifications in #content. Other notifications (like "You're now helping to test multi-process in Nightly") are unaffected.
Has STR: --- → yes
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Component: General → Developer Tools: Framework
I expect a similar fix will work in bug 1202184 but I don't have the time to investigate this.
Sorry, this bug lacks some information.
I found out that deforming notifications is probably something different than "leaving useless white rectangle". I can get the former by using STR_2. I hesitated to separate these 2 scenarios from each other, because I mistakenly filed the same bug twice, and wanted to use it for additional scenario

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_2:
0. Open about:plugins, set Flash to "Ask To Activate"
1. Open attached "testcase 2"
2. Hide hidden plugin notification and right-click on the page  [OR]  do nothing
3. Open devtools (F12)
4. Resize devtools toolbox a bit
5. Close all notifications at the top of the page
6. (bonus) Open http://example.org in the same tab

AR:  Notifications leave empty white area
ER:  There should be no empty areas

If STR_2 isn't fixed by your patch: please use bug 1256060 as follow-up for STR_2 if possible.
// btw, wow, somebody did read bug 1202184
See Also: → 1256060
I haven't looked at bug 1256060 in detail, but off-hand I'd expect this fix to address both STR, STR_2, and that bug. The issue is that the devtools splitter causes the container of the notifications to be resized and its height to be fixed (it is unspecified before using the splitter). The white area is because the notificationbox then stays the height that the splitter made it even when the notifications in it have all disappeared.

The fix I attached to this bug makes it so the splitter doesn't touch the notificationbox at all.
Comment on attachment 8768825 [details]
Bug 1208489 - use resizebefore attribute on devtools horizontal splitter to avoid resizing notificationboxen,

https://reviewboard.mozilla.org/r/62848/#review59816

Confirmed this fixes the problem, thanks
Attachment #8768825 - Flags: review?(bgrinstead) → review+
https://reviewboard.mozilla.org/r/62848/#review59818

Please update the commit message - looks like a typo at the end
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/8e07e417a5bb
use resizebefore attribute on devtools horizontal splitter to avoid resizing notificationboxes, r=bgrins
https://hg.mozilla.org/mozilla-central/rev/8e07e417a5bb
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
Arni can you verify this and/or STR2 and/or whether bug 1256060 is addressed with this fix? If you get to it today, you might need to use a mozilla-central/fx-team build, not sure this will make today's nightly.
Flags: needinfo?(arni2033)
Affected:   Win7_64, Nightly 50, 32bit, ID 20160707083343 (2016-07-07)
Affected:   Win7_64, Nightly 50, 32bit, fx-team, e1007823c2e7

Fixed on:   Win7_64, Nightly 50, 32bit, fx-team, 8e07e417a5bb
Fixed on:   Win7_64, Nightly 50, 32bit, ID 20160708030216 (2016-07-08)

All scenarios are fixed. Comment 6 explains everything
Status: RESOLVED → VERIFIED
Flags: needinfo?(arni2033)
Duplicate of this bug: 1256060
Comment on attachment 8768825 [details]
Bug 1208489 - use resizebefore attribute on devtools horizontal splitter to avoid resizing notificationboxen,

Approval Request Comment
[Feature/regressing bug #]: n/a
[User impact if declined]: broken resizing behaviour when resizing the devtools that breaks notificationboxes
[Describe test coverage new/current, TreeHerder]: nope
[Risks and why]: very low risk, 1-line patch + comment explaining what's going on
[String/UUID change made/needed]: nope
Attachment #8768825 - Flags: approval-mozilla-aurora?
Comment on attachment 8768825 [details]
Bug 1208489 - use resizebefore attribute on devtools horizontal splitter to avoid resizing notificationboxen,

Fix a minor dev tools issue, seems fine to bring this to aurora.
Attachment #8768825 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.