Allow setting incognito mode always on

RESOLVED DUPLICATE of bug 1181222

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 1181222
3 years ago
3 years ago

People

(Reporter: u550630, Unassigned)

Tracking

40 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Android; Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Build ID: 20150805074035
Firefox for Android

Steps to reproduce:

I walways enable incognito mode manually



Expected results:

There should be a setting like in the desktop version to always enable incognito. Because for 1 I like the dark theme better, 2 I prefer not to store history. I never use history and I feel storing it is only a privacy concern.

Updated

3 years ago
Severity: normal → enhancement
Component: Untriaged → Settings and Preferences
OS: Unspecified → Android
Product: Firefox → Firefox for Android
Hardware: Unspecified → ARM
Version: 40 Branch → Firefox 40
We have an option to always open external links in private browsing: bug 1065004.

Ally, why didn't we move forward with pb all-the-time? Is there another bug open for that work?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(ally)
See Also: → bug 1065004
We didn't move it forward because the consensus from Product is that very few people want pb all the time; we would need people to have a way to open a normal tab and a clean satisfactory UX for that was never determined. Interaction with tab queues was a concern as well.

I understand from mfinkle that 'always open external links in private browsing' is likely to be backed out soon.

The closest we have to incognito all the time, as I understand is the 'always clear on exit'. 

In general I support parity with Desktop. Barbara & Margaret, given our renewed focus on privacy, I'd like us to consider this for 45. What do you think?
Flags: needinfo?(margaret.leibovic)
Flags: needinfo?(bbermes)
Flags: needinfo?(ally)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1181222

Comment 4

3 years ago
See more discussion in bug 1181222.
Flags: needinfo?(margaret.leibovic)
Flags: needinfo?(bbermes)
You need to log in before you can comment on or make changes to this bug.