Scroll is not independent for each section in the History split panel

VERIFIED FIXED in Firefox 44

Status

()

Firefox for Android
General
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: u421692, Assigned: friedger, Mentored)

Tracking

(Depends on: 1 bug)

Trunk
Firefox 44
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 verified)

Details

(Whiteboard: [lang=java][good first bug])

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8666053 [details]
video1.mp4

Steps to reproduce:
1. Make sure you have History populated
2. Go to History panel and tap on Today section
3. Scroll down the list
4. Tap on Yesterday section and observe the scroll position

Expected result:
On the Yesterday section, the history entries on the right are in the initial position 

Actual result:
The history entries for Yesterday section, are scrolled exactly the same position as the Today section
(see attached video)
Mentor: s.kaspari@gmail.com, vivekb.balakrishnan@gmail.com
Whiteboard: [lang=java][good first bug]
(Assignee)

Comment 1

2 years ago
I suggest to add                         
```
mList.smoothScrollToPosition(0);
```

in the item click listener. I am currently browsing the docs how to submit a patch...
(Assignee)

Comment 2

2 years ago
Created attachment 8669472 [details]
Screen record of proposed solution device-2015-10-04-225729.mp4
Hi there and welcome! :) (You might want to set a name or nickname in your bugzilla profile)

(In reply to mail from comment #1)
> I suggest to add                         
> ```
> mList.smoothScrollToPosition(0);
> ```
> 
> in the item click listener. I am currently browsing the docs how to submit a
> patch...

I like it! Are you using Mercurial? Here's a guide on how to create a patch:
https://developer.mozilla.org/en-US/docs/Mercurial/Using_Mercurial#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F

If you need more help: You can find me (sebastian) and other helpful people in #mobile on irc.mozilla.org. For IRC setup instructions, see https://wiki.mozilla.org/IRC
Assignee: nobody → mail
(Assignee)

Comment 4

2 years ago
Created attachment 8669900 [details] [diff] [review]
fix with smooth scrolling (friedger.patch)

patch attached using smooth scrolling
Attachment #8669900 - Flags: review?(s.kaspari)
Comment on attachment 8669900 [details] [diff] [review]
fix with smooth scrolling (friedger.patch)

Review of attachment 8669900 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. Thanks!
Attachment #8669900 - Flags: review?(s.kaspari) → review+
(Assignee)

Comment 6

2 years ago
I received an automated email to get the patch checked in. I thought I follow the required steps. Is there anything left I need to do? 

Thanks for the mentoring :-)
(In reply to friedger from comment #6)
> I received an automated email to get the patch checked in. I thought I
> follow the required steps. Is there anything left I need to do? 

Oh, sorry! I should explain the next steps. Especially as one of them has to be triggered by me. :)

So, the next steps are:

1. Push the patch to try[1]. The try server will build the app and run some tests, depending on configuration. This will require hg level 1 access, so I'll do it for you in a second and post the link here.

2. If everything is green on try then add the checkin-needed keyword to this bug. Someone with hg level 3 access will come along and commit and push your patch.

3. Your change will land in fx-team[3] and then be merged from there to mozilla-central[4]. After that it will show up in the next Nightly[5] builds. :)

For future patches add "r=name" (in this case: r=sebastian) to the commit message to identify who reviewed the patch[6]. But in this case the friendly person commiting and pushing the patch will add it. :)

[1] https://wiki.mozilla.org/Build:TryServer
[2] https://www.mozilla.org/en-US/about/governance/policies/commit/access-policy/
[3] http://hg.mozilla.org/integration/fx-team
[4] https://hg.mozilla.org/mozilla-central/
[5] https://nightly.mozilla.org/ 
[6] https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Committing_Rules_and_Responsibilities#Commit_message_restrictions
(In reply to Sebastian Kaspari (:sebastian) from comment #8)
> Here we go:
> https://hg.mozilla.org/try/pushloghtml?changeset=fb72037abd21

I just realized I posted the pushlog. :-)

This is the link to follow the progress:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=fb72037abd21
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/b8fc552d0667
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox44: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 44

Updated

2 years ago
Depends on: 1213760
(Reporter)

Comment 12

2 years ago
Marking this as Verified, since there is a follow up bug 1213760 for this issue
Status: RESOLVED → VERIFIED
status-firefox44: fixed → verified
You need to log in before you can comment on or make changes to this bug.