Text rendering issues when gfx.content.azure.backends is set to "skia"

NEW
Unassigned

Status

()

defect
P3
normal
4 years ago
2 years ago

People

(Reporter: linuxhippy, Unassigned)

Tracking

(Blocks 1 bug)

44 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(4 attachments)

Posted image skia_cairo.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20150925030206

Steps to reproduce:

1. Set gfx.content.azure.backends=skia
2. opened facebook,  text rendering issues were visible


Actual results:

there are text-rendering issues with gfx.content.azure.backends set to skia, even when gfx.canvas.azure.accelerated =false (so no graphic driver issues.
Screenshot attached


Expected results:

same result as with gfx.content.azure.backends=cairo
Experienced exactly the same issue on Amazon.com, Screenshot attached.
Summary: Text rendering issues on facebook when gfx.content.azure.backends is set to "skia" → Text rendering issues when gfx.content.azure.backends is set to "skia"
Group: core-security
Component: Untriaged → Graphics: Text
Product: Firefox → Core
Sorry for the core-security flag, it was a bad click.
Group: core-security
I have the same problem and I have uploaded a few screenshots here:
https://github.com/bohoomil/fontconfig-ultimate/issues/126

I only noticed this problem since I updated to freetype 2.6.2, that’s why I reported the problem there.

Switching back to cairo solved the font rendering for me completely.
Downgrading to freetype 2.6.1 solved some of my problem but not all, so this is also definitely related to the freetype version.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 1038800
Just checked with the newest nightly, which has bug 1082598, and this is still an issue.
Yeah.. I think right now that simply isn't a supported configuration. There's more bugs than just that when using content skia. I think these days it actually crashes. Lee is doing the work to make Skia content work so making sure he's CC'ed.
Whiteboard: [gfx-noted]
Same problem here with Iceweasel 46.0a2 (2016-02-17)from Debian Mozilla team on Debian Sid 64 bits & libfreetype6 2.6.3-3
Possibly a dup of bug 1265615 where autohinting settings are not consistent between Cairo and Skia, leading to disagreements between the metrics and rendering code, causing some glyphs to be cropped.
See Also: → 1265615
You need to log in before you can comment on or make changes to this bug.