Oddly displayed images on http://www.dmm.com/netgame/ by enabling image.downscale-during-decode.enabled

RESOLVED DUPLICATE of bug 1207378

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 1207378
2 years ago
2 years ago

People

(Reporter: Toshihiro Yamada, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
RTP:
1. set image.downscale-during-decode.enabled true
2. Open http://www.dmm.com/netgame/

Expected result:
All images are displayed normally.

Actual result:
Some images aren't displayed normally.

After setting image.downscale-during-decode.enabled false, all images displayed normally.

Graphic section in about:support:

Adapter Description: AMD Radeon HD 7700 Series
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 1024
Asynchronous Pan/Zoom: none
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 100
Device ID: 0x683d
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.17461)
Driver Date: 7-15-2015
Driver Version: 15.200.1062.0
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 00000000
Supports Hardware H264 Decoding: Yes
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon HD 7700 Series Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(seth)
The affected images are GIFs and I can't reproduce on a build that includes bug 1207378. Looks like a dupe. The patch should end up in a Nightly release on Monday; sorry for the trouble!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(seth)
Resolution: --- → DUPLICATE
Duplicate of bug: 1207378
(Reporter)

Comment 2

2 years ago
I tested patches in bug 1207378 and confirmed fixed the problem.

Thanks you for your works, Seth!
You need to log in before you can comment on or make changes to this bug.