Firefox 41 hangs on websites with Adobe Flash (JW Player)

RESOLVED DUPLICATE of bug 1207766

Status

()

RESOLVED DUPLICATE of bug 1207766
3 years ago
3 years ago

People

(Reporter: infinium, Unassigned)

Tracking

({crash, flashplayer, shockwave})

41 Branch
Unspecified
Windows 7
crash, flashplayer, shockwave
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150917150946

Steps to reproduce:

When you open a web page with multiple instances of a flash video player (JW Player) Firefox 41 freezes. It's not a JW Player (old and tested version) or Flash issue as the sites open normally in all other major browsers - new and old (see below).

Bug seen on two laptops with Win 7 Ultimate(64-bit) with Firefox 41 and Flash 19.0.0.185 and on a Windows XP desktop with the same versions of Firefox and Flash installed. 

The bug is most easily reproduced on sites with multiple instances of JW Player (http://www.nauteka.bg/sciences/video/krasiva-animatsiya-pokazva-hilyadi-kandidat-planeti-otkriti-ot-teleskopa-kepler-video/, http://www.geenstijl.nl) that play mp4 files. Sometimes you have to reload the page to make the bug work. I tried all the tricks with Hardware Acceleration turned off, Adobe Flash protected mode turned off etc. - nothing works.

The problem is not caused by Flash but Firefox 41 (or their interaction) as I am able to open the sites in all other major browsers (Chrome 45, IE11, IE10, IE9, IE8, Opera, Firefox 3.6, Safari for Windows 5.1.7) - even Internet Explorer 7 doesn't have any problems!

Other people complaining about the issue: https://www.reddit.com/r/firefox/comments/3m7hck/firefox_410_freezescrashes_on_wwwgeenstijlnl/


Actual results:

Firefox 41 becomes unresponsive ("Not Responding" in title bar) and you have to force close it: fist clicking on "X"->Close This Program. Even if you wait a long time it doesn't crash on its own and just stays frozen. When you force close Firefox a message shows that "Plugin Container" has crashed and you have to force close it as well.


Expected results:

Sites with multiple instances of JW Player or other Adobe Flash functionality should open normally.
(Reporter)

Updated

3 years ago
Keywords: flashplayer
(Reporter)

Updated

3 years ago
Keywords: crash, shockwave
(Reporter)

Updated

3 years ago
Component: Untriaged → General
OS: Unspecified → Windows 7
(Reporter)

Comment 1

3 years ago
NOTE: The bug is still there in Safe Mode with addons disabled. In privacy mode as well. Tested with prefs.js renamed (disabled) in profile folder - bug is still there.

Comment 2

3 years ago
try to kill the plugincontainer process  to view if the browser got back responsive
(Reporter)

Comment 3

3 years ago
(In reply to besrml from comment #2)
> try to kill the plugincontainer process  to view if the browser got back
> responsive

Yes, it got back responsive and in place of the JW Player there is a message "The Adobe Flash plugin has crashed" (No report available).

Updated

3 years ago
Component: General → Plug-ins
Product: Firefox → Core

Comment 4

3 years ago
Hi, it affects me too. And I confirm that killing pluginconter brings back to life firefox.
Best regards.

Comment 5

3 years ago
I find the problem almos gone if change the values of two boolean entries:dom.ipc.plugins.asyncInit 
and dom.ipc.plugins.asyncInit.enabled.

First i try dom.ipc.plugins.asyncInit.enabled/true, the problem ocurrence was greater reduced. After the test i find in the browser another option related dom.ipc.plugins.asyncInit,viewing the settings in the pref.js file in release and aurora versions of firefox.

Using the default values of dom.ipc.plugins.asyncInit/.enabled the crash happen regularly, now i'm trying both entries setted to false.

Comment 6

3 years ago
ok i'm going to test your workaround.

Furthermore I add my infos :
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Nvidia GTX 460 driver 355.98

(It's a very annoying regression imo because I tried with a clean profil and without adds-on and same issue)
(Reporter)

Comment 7

3 years ago
(In reply to besrml from comment #5)
> I find the problem almos gone if change the values of two boolean
> entries:dom.ipc.plugins.asyncInit 
> and dom.ipc.plugins.asyncInit.enabled.
> 

So you think it's related to Bug 1198590 ?

Updated

3 years ago
Flags: needinfo?(aklotz)

Comment 8

3 years ago
I've reproduced this with the sites you give and it is the same hang as 1207766.

Thanks for reporting this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(aklotz)
Resolution: --- → DUPLICATE
Duplicate of bug: 1207766
You need to log in before you can comment on or make changes to this bug.