some characters are not allowed in variable names even if ES6 allows them

RESOLVED DUPLICATE of bug 917436

Status

()

defect
RESOLVED DUPLICATE of bug 917436
4 years ago
4 years ago

People

(Reporter: m93a.cz, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150921004016

Steps to reproduce:

Open a JavaScript console, type "var 
Reporter

Comment 1

4 years ago
It seems the character has also broken Bugzilla. The thing is that double struck characters http://www.w3.org/TR/MathML2/double-struck.html are interpreted as invalid in variable names even though ES6 allows for them. See JavaScript Variable Name Validator https://mothereff.in/js-variables#%F0%9D%94%B8 for more info.
Reporter

Updated

4 years ago
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 917436
You need to log in before you can comment on or make changes to this bug.